unable to use the Open With function on OSX finder

I updated Libre Office to the lastest 6.0.2 on High Sierra. I was previously running 5.x . I am not sure what the correct procedure is for updating, but in my case i downloaded the .dmg file. On dragging the icon to applications , I was prompted to overwrite. I did the overwrite.

LibreOffice runs fine from applications. My issue is that if I right click a file from finder, and choose Open WIth, Libre office does not run. Instead a default program is chosen. Therefore the Open WIth link is broken

I am wondering if I screwed up on the update, and possibly OSX is attempting to run the old version on the run with function? or maybe there is an issue with the installer? I tried deleting libre office, which removed it from run with. Then I reinstalled from scratch, but this made no difference. Any suggestions welcome.

got some advice off the Apple support forum. Looks like this is an OSX issue. I was able to use the get info window to set Libreoffice as the default for .doc. Problem solved.