Undelete is non-functional for TL4 users

There is expected to be an “undelete” function for just deleted posts:

However, this is not working, since deleting anything only flashes the “undelete” button, after which the deleted post disappears along with the button; and trying to double-click the briefly-appearing button gives this error:


Is there a reason to disallow this function on this site?

Don’t think we changed the default settings regarding (un)deletion.

A quick look in the log suggests that all the posts you tried to delete are in a private conversation, maybe the undelete doesn’t apply here? Can you try to do it a non-private topic?

That was a “discobot” tutorials, that are indeed private conversations; and indeed, what discobo suggests there is intended to work there :wink:

I tried here, and it doesn’t work, either :slight_smile:

I believe this was fixed upstream at FIX: TL4 users can see their deleted posts (#13364) · discourse/discourse@e70e8d8 · GitHub , let’s try again after we upgrade. FWIW I think TL≤3 users are not affected and can recover (subject to rate-limiting) the posts they authored and deleted.

1 Like