Unexpected Err:522 after FullScreen set

Weirdest thing. After choosing FullScreen view (Ctrl-Shift-J) and changing one cell, some others display Err:522.

This happens even if the cell modified is filled with the same value!

Going out of FullScreen mode and modifying the cell once more, resolves it.

Any thoughts?

What version of LO are you using? In when I do Ctl-Shift-J most of the time I get a gray screen. Then if I click somewhere, some of the cells show up, but not all. Click somewhere else and a few more show up. One time the whole thing worked correctly, so it’s intermittent. But in LO works!
OS: Debian 9.5 (x86-64);
Cinnamon: 3.2.7;
Linux Kernel: 4.9.0-7-amd64;
Processor: Intel Core 2 Duo P8800;
Graphics Card: AMD/ATI RV710/M92 Mobility Radeon HD 4530/4570/545v

Err:522 indicates a circular reference in formula cells (at least one depending on another cell that again, directly or indirectly, depends on that one cell). It may be that the larger view triggers more cells to be recalculated than the smaller view. Inspect with invoking the Detective (Tools → Detective → Trace Error) on the error cell.

If the circular reference is by design then you need to enable iterations (Tools → Options → Calc → Calculate, “Iterative References”) with proper steps and epsilon values for that document.

No circular references. Just a simple, small sheet. If I zoom out to 75%, all cells are visible: just 35 rows and 24 cols. Changing a particular cell causes Err:522 to appear, only when in FullScreen mode. Ctrl-Shift-F9 (Recalc everything) “fixes” it, but it sure feels like a bug under the hood somewhere.

Which version and OS anyway?

I’m getting a 522 for no reason also, probably a bug

Similar situation here: 522 popping verywhere when just resizing columns, then disappearing by recalculating (F9). Guys, I thought only MS could couple so badly a GUI feature with a core one, but I was wrong :slight_smile:

I have a formula repeated over 60 columns that worked without a hitch up to column AZ. At BA Err.522 appeared, suggesting a limit of 52 columns. I used the Detective as suggested above and it identified a constant back in B18 used by the formula (the same constant & location successfully used up to AZ). I removed the reference and duplicated the constant in each column, changed the formula accordingly and error 52 did not recur.
This seems therefore to be a bug such that reference to a cell more than 52 columns back returns Err.522. A relevant error message should be created.
OS Windows 10, v 2004
LO v

A reference 52 columns to the left alone certainly is not the trigger, but maybe something the formulas share / have in common in combination therewith. It would be good if you created a bug report and attach the erroneous document (or rather a smallest possible reproducer) after having removed sensitive information. Thanks.