Unhandled exception: cannot get uno environment!

I installed LibreOffice rel 3.6.0 under Windows 7 and each time I try starting LibreOffice, or any LibreOffice application, I get a Fatal Error pop-up containing this error message :

Unhandled exception: cannot get uno environments!

I tried, reinstalling 3.5.5 just to check my Windows installation, it runs fine.

I checked the md5sum of the dowloaded ;msi file (it’s OK).
Re installed 3.6.0 and the problem is still there.

What’s next ?

Thanks for your help


Quite often, there are issues with the user profile when updating to a new version. Try renaming the profile directory.

I ran into the very same problem today. Installed LibreOffice 3.6 under Win7 (x64). Get the same “Unhandled exception: cannot get uno environments!” and after that, I got a MS Visual C++ Runtime Library error message about soffice.bin: “This application has requested the Runtime to terminate it in an unusual way”.

As suggested by tohuwawohu, I did rename my profile directory (AppData\Roaming\LibreOffice\3\user) into “user-old”, then tried starting LibreOffice again. This did not help at all: I just got the very same error screens again.

Interestingly, it turned out this LibreOffice startup had actually tried to create a new “user” profile directory before it aborted. But this new profile directory contained nothing but one empty “user\extensions\bundled” folder.

Can someone please help? There seems to be something seriously wrong here!

After searching and numerous tries, I got it running.
I had to :

  • uninstall LO and the associated HelpPack
  • remove the LibreOffice folder from user Profile (–> trashfolder)
  • reinstall LO 3.6.0

But now a General comment about ask.LibreOffice.org
It’s very difficult to use, it’s all but user friendly!
You allways need more Karma Points to achieve your tasks.
The effortlevel for posting here is higher than that for searching on other sites. I thought uploading an avatar would improve karma. Nope! you need those stupid points.
It seems this site has been set up by geeks for geeks. It’s not usable by Joe user ! How can I show to non IT people it is very simple to get helped with LibreOffice ?

I won’t use this site any more as long as posting remains a nightmare

I agree to both: Uninstalling and re-installing LO solved the issue for me either and this annoying karma/point system here does nothing but preventing us from helping each other.

@ PhilDur:
your strategy of a complete uninstall followed by a clean reinstall turned out to work.
Thank you so much!
Still it’s a little strange that the LO people haven’t noticed this problem - something must be wrong here.
Sorry to hear this site doesn’t work for you. I don’t understand what your problem with the site is, as it works fine for me.
Anyway, thanks again, Henk

It’s simply that the site user’s guide is at least minimal ;-). For instance i’m still loking for how to insert a line break in a comment. The html br tag does not appear to work as ot does in responses or questions! Strange, isn’t it?
I tried to force a line break befor this sentence.

Have exactly the same problem on an x32 windows 7 i5 system.
Tried the uninstall, then remove Libeoffice folders in program files and then reinstall 3.6.0 and it still has the same problem.
Have gone back to 3.5.5 successfully.

I had this “uno environments” problem too, on any attempt to run Calc v3.6.

Downloaded 3.6.1 today, uninstalled 3.6 first, installed 3.6.1, and now it works.

Win7 x86 (i.e., 32 bit).

Oh p.s. had the help files installed too; uninstalled first and reinstalled last. Probably makes no difference :wink:

3.6.1 worked perfectly last night. Now it won’t load as above. If LibreOffice is trying to break into the business environment, it had better get it together, the sooner, the better. Where’s the solution? Where’s the answer to this:

unhandled exception cannot get uno environments

To have software that loads fine twelve hours ago, and not load at all today, is completely unacceptable.

Again, where’s the fix? It doesn’t appear in this forum.

Hello PhilDur,

I had the very same problem after I upgraded from 3.5.6 to 3.6.2. I found the reason for this error to be the deselection of the UNO language environment during the installation procedure. It was installed in my previous version. The solution was quite easy: I simply used setup program (“Control Panel” → “Uninstall a program” → select LibreOffice → “Change”) to add the UNO environment and ever since it works.



I have the same problem. I updated from v3.5.x to v3.6.x and now I cannot start LibreOffice anymore.

Very, very aggravating! Please fix this ASAP!