Unintended words being replaced by autocorrect

I am typing a non-ordered bullet point in Writer. I get to the end of the phrase and type, ‘you[ENTER]’. The word ‘you’ is changed to ‘younger’; ‘him’ is changed to ‘himself’.

Typing an ending space removes this behavior. And I see that the next time I put the cursor on that bullet point, the appended space has been removed.

Why doesn’t the program also recognize ‘you’ as a valid word? And ‘you’ is a lot more common than ‘younger’!


This doesn’t happen on my LibreOffice on GNU/Linux distribution openSUSE Leap 15.2 using native packages from TDF (libreoffice.org) and having set paragraph language to English (USA).

Choose menu Tools - AutoCorrect - AutoCorrect Options… - Word Completion tab, and check the values there.

See LibreOffice Help on Word Completion.

LibreOffice (x86); OS: Windows 6.1.

Add Answer is reserved for solutions.

Press edit below your question if you want to add more information; also can comment an answer.

Check the mark (Correct answer mark) to the left of the answer that solves your question.