update context menu when right clicking in a cell

I miss some options in the context menu when I click right in a cell in calc. I tried to update the context menu via tools/modify, but nothing seems to happen. Only when you go there again you see your own additions but the menu I see when right clicking in a cell, is not changed. Appreciate some advice.

Could you please be more specific? Your question is a bit vague by using phrases, which leave about details in the dark …

miss some options - Which options do you miss?
tried to update… - update using what entries, how and into which target?
nothing seems to happen - what do you expect to happen?

see right click menu in a cell for example of menu I want to add to.
I want following options there: add hyperlink, modify hyperlink and remove hyperlink. Hope this makes it clear? See also this picture: tools/modify

I cannot see the problem - tried that and it appears to work as designed.
Right click on an empty cell: Only Hyperlink is visible (of course Edit & Remove are invisible, since there is no hyperlink yet)

Right click on cell containing hyperlink:

image description

My test on (which is your LibreOffice Version ?)

Version:, Build ID: b0a288ab3d2d4774cb44b62f04d5d28733ac6df8
CPU threads: 8; OS: Linux 4.12; UI render: default; VCL: kf5; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US, Calc: threaded

Version info:
Versie: (x64)
Build ID: f82ddfca21ebc1e222a662a32b25c0c9d20169ee
CPU-threads: 12; Besturingssysteem: Windows 10.0; UI-render: standaard; VCL: win;
Locale: nl-NL (nl_NL); UI-taal: nl-NL
Calc: CL

Further, it states I’ve the ‘lastest’ version. When I go into tools/modify, I select the contect menu tab, but then, what target do I need to change? I tried Cell, Cell Hyperlink… and added the options there, but my right click menu when in a cell does not change

Just did another test in a different document and now I do see the hyperlink option.