Update: Edit all signs of one kind

Hello everyone,

!!Important!! Read the update below!

I am writing a thesis on japanese philosophy and religion, and therefore I have to use the japanese Kanji signs in my document. When I pasted them (because I don’t have a japanese keyboard) they were perfectly fine and visible. Today I opened my document again and now my Kanji are gone. I tried copying the blank space and the Kanji are visible.
To show this:

what the document looks like

jidai (時代)

what is in my clipboard if I copy it

Does anyone know how I can fix this? :confused:

thanks in advance and have a nice day,

Update: So now I figured that if I change the font the Kanji are visible again for God know why. I’ve already used quite a lot in my document, is there an option where I can the font and size of every Sign of one kind (so in this case change all japanese signs to have font A and size B) at once?

It’s possible to change the font and font size of Latin and CJK text separately if you use the style or formatting dialogs. But, if you want to change the default everywhere, it may be best to change them in Tools > Options > LibreOffice Writer > Basic Fonts.

You may need to enable Asian Language Support first: Tools > Options > Language Settings > Languages.

Finally, you may need to reset direct formatting (ctrl+m) from text you formatted manually in order to get everything consistent.