Upgrade fails with HKEY_LOCAL_MACHINE32 error

Upgrade to 4.4.5 fails with permissions error 1402 to non-existent registry key: HKEY_LOCAL_MACHINE32\SOFTWARE\Microsoft\Windows\CurrentVersion\SharedDLLs. Regedit search for “HKEY_LOCAL_MACHINE32” resulted in nothing found. OS recently upgraded from Win 7/PRO to Win 10.

Upgrading from Version: OS is Windows 10/Pro X64.

Same problem with Windows 7 Pro 64-bit. Original install.

There is no HKEY_LOCAL_MACHINE32 in my registry at all.

Install fails. It succeeded on another similar machine, though, but with a non-pro Win 7 64 version.

Hi npoulsen

Try the steps in Q59788 (MS Fix-It, a M$ site designed to fix Registry Corruption for those that have install/upgrade/removal problems).

Thanks for your help, Alex, but I get “We’re sorry, but your operating system is not supported by Microsoft Fix it at this time.” when I tried it. I’m committed to Win 10 Pro, so there’s no going back to 7 to try the fix. repair/uninstall fails also. Not sure what else to try.

Not much of a solution to the original issue, but I finally got 4.4.5 installed. I had to use CCleaner to uninstall since neither repair/uninstall nor Windows 10 remove program worked. Both failed on registry permissions errors due to non-existent registry key. I then installed 4.4.5 with no problem. Only conclusion I can come to is that the upgrade to Win 10/Pro x64 removed “HKEY_LOCAL_MACHINE32” registry entries for at least LibreOffice and possibly all other x86 (32 bit software) installations. Scary thought!