Upgrade from 4.4.2 to 7.5.2

I created a libreoffice database program in 2016 using 4.4.2 and xampp on windows 10.
The program perfectly worked without error.
After the customer bought a new Windows 11 computer, I installed libreoffice to 7.5.2 with xampp 3.3.0 and loaded the ODB file
I’m now getting this error
SELECT * FROM security.filter WHERE ( security.filter.rosterID = :link_from_RosterID )

from this SQL statement
SELECT hours.Team, hours.RosterID, hours.Dateworked, hours.Hours, memberPersonalInfo.First_Name, memberPersonalInfo.Last_Name FROM security.memberpersonalinfo AS memberPersonalInfo, security.hours AS hours WHERE memberPersonalInfo.RosterID = hours.RosterID AND hours.Team = ? ORDER BY hours.Team ASC

Any ideas what could be causing this ??


At this moment, I have no clue, why your select statement should give another select-statement as an error…
You really got the following text in a MsgBox as error?
SELECT * FROM security.filterWHERE (security.filter.rosterID = :link_from_RosterID )

The basic things are working? You can see the tables? Are other queries ok?

1 Like

@BobDe1 : Which database connection do you use?
Might be something like Edit → Database → Advanced Settings → Special Settings → Replace named parameters with ‘?’.
For MySQL/MariaDB without this setting: See Bug 50747.
Open the *.odb-file with a packing-program. Edit the file content.xml.
db: parameter-name-substitution = “false”
must be set to “true” or could completely been removed.

Thanks for the info… Sorry for the delay in getting back to you but my internet has been down since Friday and I have to drive a mile and a half to get online, research the problem, drive home try it out, then rinse and repeat. Here is what I’ve found so far… If I run the query (the query has two linked tables) it works perfectly, but when I use the form I get the error. The connection on the original program was “MYSQL (native)”. LO 7.5.3 does not have that.
I can’t find “Replace named parameters with ‘?’” anywhere. Open the *.odb-file with a packing-
program. What is a packing-program?

Thank you for all your help


Might be it is called app for zipping files. All LibreOffice-files are compressed folders.
The app here on my Linux system is “ark” - works with different compressing modes.

For Windows typical programs are 7zip or old WinZip, but Windows has integrated suppurt for zip-files.
As the usual Open-Document-files we use are essentially zip-Archives, just make a copy of your .odb and rename it afterwards to .zip (You may also use .odb.zip )
There will be a warning, if you really wish to change the extension.
If you can not see the extension .odb you may need to configure Windows Explorer to show them. Usually MS suppress extensions for "known files’.
Now you can open/use the zip-file like a folder. Check context menu for files: Extract you can use to get (a copy of) sometimg out of the zip-archive.

Me too. Usually you find in the second Menu from the left as last entry “Database”. My Sqlite via odbc-driver shows the named setting at extended properties. The MySQL-connector does not (LO7.5 on Win10 pro / connection with local MariaDB).

Perfect, worked like a charm…
Thank You very much…