Upgrade from version to and received an Error1335 - WinXP sp3

I am attempted an upgrade from version to and received an Error1335 - cabinet libreoffice1.cab corruption.
I had tried various download methods (direct from more than one mirror site and via torrent) with same result. Testing of msi file via 7-Zip passed and no virus present as per avast!
Noted after rollback that was no longer installed. Attempted reinstall of from original working install file ended with the same install error of 1335.
I removed as many entries as I could of any LibreOffice installs via a registry cleaner and manually searching for any LibreOffice entries via Regedit, and any LibreOffice folder in the folder of “Program Files”. Install error still persists. I am currently running Win XP sp3. I do have an old version of OpenOffice 3.3 on my system that is still functioning, and has not been a barrier in the past to installs of LibreOffice (I do not run the I do not run either with system startup.)
I have now even stripped my system of Java to see if that has any effect. I still am stuck with error 1335. Can anybody be of assistance? Am I missing a folder or registery entry that is causing this error? Any suggestions?
Thanks in advance.

Out of curiosity: Why should one update to 4.2.8 when 4.3.5 is the most bugfixed version in the 4.x.y series? The only reasonable “still” alternative which should be less buggy (and less feature-rich in some sense) is 3.6.7. It also is the final version to support the “legacy” file formats.

Let’s see how we can get you up and running again. I also have an XP/SP3 machine. The only difference is that I used always only one installation, however it is possible to have 2.

I understand that you had 3.3 and 4.2.7 running on the same machine without problems. Please confirm.

System reset:
I recommend to make first a system reset to the status before your attempt to upgrade:
Start > All Programs > Accessories > System Tools > System Restore and use the latest restore point before you started the installation of 4.2.8.
With this I hope to rescue your registry files and enable a normal uninstall

Normally you don’t need to uninstall the old version; the new installs itself on top. As you started to uninstall 4.2.7 I I would also remove all traces.

You "…removed as many entries…"is what worries me a bit. The normal way to uninstall a SW in XP is
Control panel > Add and Remove Programs > select LibreOffice and uninstall. Try if you can still do this and inform on that. Please report on all steps (and their results) you took to do the your uninstallation.

Additionally you should - if not removed already - rename the user folder of LibreOffice folder in the Application Folder:
Under your user name look for Application Data > LibreOffice > 4 (this contains all folder for version 4) and rename this Folder to 4Old - Renaming is better because you might be able to use your user profile or parts of it later again.
You should also have one folder “3” for the 3.3 version.

By now I hope that your windows has no problems and you are ready to make a new installation. You could actually create a new restore point. Keep notes of your restore points.

I recommend to make a new download of the msi-file from http://www.libreoffice.org/
There select the version you want and download the msi-file

I don’t know what kind of test you made with 7-zip; I normally don’t test LibO downloads from the aforementioned site. In your case it might be good - at least this time - to check the downloaded file using hash tags. You find them when you click info just right under the green download button.

Please confirm the steps taken and results obtained.

Now you should be ready for a new installation. As you still have 3.3 installed you need to follow the instructions for parallel installation. Here is the guideline:

If you want only 1 LibreOffice installation I recommend to uninstall also 3.3. I observed some smaller problems when I installed my first version of 4.0.

Good luck!

Please see “Your Answer” section for response to answer above. “Comment” section does not allow enough characters fro a complete update.

Dear ROSt52,
Thank you very much for your swift and detailed response.
Just some clarifications:

  1. The 3.3 install in OPENoffice.
  2. The LIBREoffice 4.2.7 install was uninstalled by the LIBREoffice 4.2.8 install program. When the 4.2.8 install failed, the install’s Rollback process left a bunch 4.2.7 files and settings that was non-functional and removed the Windows’ 4.2.7 uninstall process.
  3. Because other programs and process had taken effect (security, utilities, updates etc.) in the interim, I was a little anxious to do backward system restores and had elected to try registry cleaners and manual registry edits. It seems that either some traces are still left in the registry or system files or some other conflict because it still failed.
    Due to the concern of irreversible System Restores, I installed a Forward capable System Restore utility before trying your suggestion of System Restores. I then tried to do a System Restore to a point prior to the 4.2.8 failed install. (A time when 4.2.7 was working). The system failed to start into Windows, and required that a Forward Restore for me to get back to where I am now.
    As a side note, I was able to install the LibreOffice 4.2.8 Portable version. It seems to be working okay. Any idea of what limitations I might expect with the portable version?
    Again, Thank you again for trying to help. It really is appreciated.
    (just some FYIs – The downloads I did was initially from the source you mentioned. I also attempted from a couple of different recommended mirrors and also another attempted using a torrent. All had the same install errors that I reported. 7-ZIP has the capability to check if compressed archive (cab, msi, zip, etc.) are intact or corrupted. It was a recommended test by one of the help forums I tapped for this problem)