upgrade to and now cant save pw protected files

I have a calc spreadsheet in odt format that is password protected. It was originally created with an earlier version of libreoffice4 but its always worked through each version upgrade until now. Recently I upgraded to on LINUX. Now whenever I try to save that modified spreadsheet, it fails with the message “error saving the document. General error. General input/output error.” I get the same message if I attempt to save-as a new name, save all, etc.

I was able to narrow it down to related to being password protected. This is a large spreadsheet with 59 sheets. I thought maybe a sheet was corrupted so I copied each sheet 1 at a time to a new document not password protected appending each additional sheet to the end and have been able to open and save that document not password protected without errors … the problem becomes, many of the cell data is linked to the old document.

I also tried to remove the password protection on the existing spreadsheet and that fails also.

Anyone have any ideas or workarounds?

I had the same error trying to save in safe mode.

Build ID: 00(Build:1)
CPU threads: 4; OS: Linux 5.5; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Debian package version: 1:7.0.0_rc1-5
Calc: CL

tdf#134332 and tdf#134796