Use a Java runtime environment checkbox will not stay checked

I get it, broken record. You’ve heard this one before… but maybe because it’s a sign something isn’t working right.

Everyone seems to treat these Java runtime questions as a beginner, invalid question, but I now empathize with all who have experienced this problem. When I first started using Base about a month ago, I went through the process of connecting a Java runtime library in the normal place: Tools - Options - LibreOffice - Advanced. Everything worked fine up until a few days ago. I don’t know what could have changed. Now the checkbox at the top “Use a Java runtime environment” will not stay checked! I go in, check the box, find the Java runtime by clicking the Add button, I make sure to click the radio box so it’s filled, and click “OK” to accept the changes.

Before, I didn’t even need to do the whole “Add” button thing to find a Java runtime path. A few Java runtimes showed up automatically, and all I had to do was pick one via the radio button. None of that happens anymore. No runtimes show up in the list, and I must add them manually.

If I go immediately back into the same place, the checkbox is no longer checked, and the list of runtimes is again blank, as if I never did any of the steps I just mentioned.

In frustration I went as far as uninstalling Java and reinstalling even though that shouldn’t be necessary. I even uninstalled LibreOffice and reinstalled the latest version. Reset my computer, all that. None of that makes any difference. The checkbox will not stay checked even if I go through those steps a hundred times, and no Java runtimes show up in the list unless I Add them (but then they go away again as soon as I save the options).

Anyone else experiencing this?

Here’s my info:

Windows 10 x64, Java 1.8.0_191-b12 64-bit, LO 64-bit

Java install path: C:\Program Files\Java\jre1.8.0_191

If I point to the /bin/ subfolder, the runtime will show up in the list, and I can select the radio button… but all that, and the checkbox go away each time I re-enter the options screen. No radio buttons or runtimes show up UNLESS I add them, even if I wait for them to appear. Nope, they never do. Used to, but no longer as of a few days ago.

Yes, all three are 64-bit versions - Windows, LibreOffice & Java runtime. I’m not clueless about this stuff. Something strange happened. It was working for a long time, and suddenly it stopped working. Is there some kind of test I can do to see if some service is maybe not running that needs to be? Only thing I can think of trying is going back to a 32-bit version of LibreOffice and Java runtime. Seems kind of ridiculous.

The primary thing I’m talking about is the checkbox. It simply won’t stay checked. It unchecks itself as soon as I save the options, and the Java runtimes no longer show up. I know I wrote this same thing about 4 times… but I want to make sure those details aren’t missed. If someone doubts it for whatever reason I can record a Youtube video to prove it. But trust me, the options don’t save!

I read through numerous questions on this forum, but none of them fix the problem I’m having with the checkbox unchecking every time.

One of the older answers to this general question mentioned a Visual C++ install. I even installed that just in case… though it was already installed and prompted for a repair, which I did. Don’t think that was the issue.

Here for your safety, a description. You wrote that you have done everything right. I do not doubt it. Then there may be another reason, such as a defective user profile. You can reset the user profile. Save the old one under a different name beforehand. How this is done, is explained here.

Thanks, @eBot. I’ll look into that. In all the answers I read, that’s one thing I did not yet see, so it’s worth trying! Hopefully it works! I definitely have to try, otherwise I literally have to can the whole LibreOffice solution, because Base is unfortunately a Christmas toasted fruitcake brick to hold the door open without Java working. I wish it just didn’t need Java, that’d be nice. I’ve been trying ODBC instead of J, but some macro functions still need Java even using ODBC connector. :frowning:

@Hrbrgr, you are a lifesaver. I was about to jump ship after all this recent trouble. Apparently my user profile got corrupted because now it’s fixed! I had to do the most drastic profile reset, but I don’t care. I barely customize LO anyway, so no loss there. All my macros are directly in the .odb files. Everything is back to normal. The checkbox is enabled by default, and the Java runtime installations show up without having to click the Add button. Very good. Thank you a bunch!

@PhLo I’m glad for you, that it works again.

@PhLo Java is not needed for most of Base. With my developed MySQL application and all the macros it contains (both in basic and Python) the only item which doesn’t work is Report Builder. Wizards also will not work but it doesn’t affect the operation of Base. You do need Java if running the embedded HSQLDB database.

I’m sure you know better than me, @Ratslinger. All I know is that because of the user profile problem, Java was out to lunch. Since MySQL JDBC connector requires Java, obviously that was dead too. Plus, isn’t the & uno stuff potentially an interaction with Java? When my user profile was corrupt, those properties were misbehaving too. Perhaps the entirety of LO was on the fritz, so maybe not specifically Java problems. Not hugely important. I’m just glad it’s kinda fixed now.