Use US/UK settings, but with danish keyboard in Calc


I have been using OO on OSX for many years and all my OpenOffice calc documents I use . (dot) as seperator when using decimals, instead of the Danish , (comma)

Now i upgrade from OSX Maverick to Catalina, and tries LibreOffice, but even if I choose UK or US as Local Setting (and user interface), tried checking the " Decimal Seperator setting to use local setting" On/Off… when i press the , on my apple USB keyboard numerical pad, it returns , (comma).

If i change my keyboard language in OSX to UK/US… til numerical retuns a . (dot) when pressing , (comma) on the numerical pad.

Can remember I had the same issue back in 2012/2014 with OO, but got i fixed then…

Is there some “bug” or some other place to get LibreOffice to use the UK/US decimal seperator . (dot) other than stop using the numerical pad and press the normal .(dot) when ever i use decimals (several tims a day)

On the numerical pad the ,/. key gives the decimal point. It will be . or , depending on the operating system setting, not LibO. On my Linux/Mint system it would be the operating system keyboard setting that determines the value of that key. These settings will determine the keyboard value passed across to LibO.

Have you explored what value Catalina is handing over to LibO?

Please check Tools -> About and what is shown in Locale (with me: Locale: (en_US.UTF-8) if I use the English UI for testing purposes and Gebietsschema: de-DE (de_DE.UTF-8) if I use my German UI. Depending on that I get a . (dot) for en-US and a , (comma) for de-DE (both with Tools -> Options -> Language Settings -> Languages - Option: Decimal separator key -> [x] Same as locale setting. I don’t need to swith an keyboard layout to make this work (I’m on Linux openSUSE 15.1) - In other words: You may give Tools -> Options -> Language Settings -> Languages - Option: Locale Setting -> Dropdown; English (USA) a try (I do force that by starting my test instance using export LANG=en_US.UTF-8;libreoffice6.3... as a start command)

Thanks for your respons

Don’t have an About under the Tools menu in LibreOffice Calc

But i think you mean the LibreOffice menu

Build ID: 98b30e735bda24bc04ab42594c85f7fd8be07b9c
CPU threads: 4; OS: Mac OS X 10.15; UI render: default; VCL: osx;
Locale: en-US (en_DK.UTF-8); UI-Language: en-US
Calc: threaded

I tried shifting between UK and US in the language settings and check the Decimal seperation pr local setting… still it uses , (comma)… unless i change the keyboard language in Catalina…

When i change my keyboard to US, nothing changes
Build ID: 98b30e735bda24bc04ab42594c85f7fd8be07b9c
CPU threads: 4; OS: Mac OS X 10.15; UI render: default; VCL: osx;
Locale: en-US (en_DK.UTF-8); UI-Language: en-US
Calc: threaded

Do not answer your own question unless it is a real answer, use the comment option or modify the original question.

As I commented earlier, there are several issues to consider here.

Keyboard. The keyboard numeric pad gives a different character for the . / , key dpending on the KEYBOARD LANGUAGE setting. It will use a decimal point when choosing a English-UK keyboard, and also English-US keyboard, likewise Indian, China etc. The keyboard will give a decimal comma for Danish and other countries that use that system.

The use of decimal . or , on the ordinary keys will depend on your software settings. In LibO this will depend on your LANGUAGES > LANGUAGE SETTINGS. (The decimal separator key). This uses your LOCALE and USER INTERFACE.

Be aware that the English-UK and English-USA are not interchangeable, both from the Keyboard Layout and the LibO settings like paper size, spellcheck etc. This is particularly important when using Mac-OS. An example of this is the print problems using American paper sizes.

I hope this answer may help a little. I feel the Keyboard numeric pad may be the simplest way to control the problem.

Tried using User interface ENGLISH (USA) with Local Settings ENGLISH (USA), with and with out Decimal seperator key: Use as local setting.

Still get comma when using the numerical pad.

If i use Loacla setting ENGLISH (UK), still get comma.

But if i change the keyboard layout in Catalina til US, i get a . (dot) when pressing the comma on the numerical pad.

Tried downloading 6.2.8 UK/GB version… still one comma

It seems to be that Catalina overrules the language settings in LibreOffice…