User defiend time field, possibly a bug?

It goes as follows: I try to make a time field on libre writer through ctrl+f2 → Additional formats… → edit one of the formats to DDD MMM YYYY HH:M (Fri Dec 1999 13:37 (in greek))-> press the check button which leads to either selecting nothing or gives weird formats like the ones shown ([HH]:MM:SS , [HH]:MM:SS.00).

image description

Prior to this, fields used to work just fine on my older OS (Win 10, version unknown), I did a format on a new ssd and installed windows on it instead (Win 10, version 10.0.17763), so there’s no prior installation of LO on the system expect from the ones mentioned.

I have tried the following:

  • Change it to automatic which sometimes stays automatic or changes to English (USA) by itself after trying to change,shows the same symptoms (nothing or weird format)
  • Tried different formats like : DDDD MMM YYYY H:M,D MMM YYYY HH:M,DDD-MMM-YYYY HH:M
  • Selecting Time (fixed) or Time has the same results.
  • Uninstalled LO and changed to version (I was using 6.2.0), fields stayed unchanged
  • Run LO on safe mode,same results
  • I deleted “Field.xba” and repaired right after followed up by a reboot as suggested. Which seems like it had nothing to do with the time fields as they stayed the same, it was a desperate attempt of fixing the issue.

I’m missing something here, what should I do from here?

You need to insert a ‘Date’ field instead of a ‘Time’ field. Time fields discard the integer (DATE) part of the internal date-time-value. Date fields keep everything despite their name, and you can display date and time in the same field then.

I would suggest to use the settings shown below. (Don’t invent a new stubborn date-time-format every other day.) Basically use ISO 8601. The day’s name may be prefixed. image description

You know… I feel like I deserve to be put in hell for this post.

Thanks a lot and sorry.

Do you mean you want to make hell a better place?

Oh youu~~~