Using Accent marks cause letter to go to next paragraph

When I use accented letters like Alt+136 (ê) it places the letter on a next line or paragraph. Very annoying.

Enable View>Formatting Marks and edit your question to describe what is revealed. No character should go on its own on next line. You probably inadvertently insert a formatting or control code.

When I use accented letters like Alt+136 (ê)

That code is a Windows thing. In Unicode, ê is identified by U+00ea. In Writer, you can move between Unicode codes and actual characters with the Alt X shortcut. If I type 00ea and immediately press Alt X I get ê without problems.

I was drinking un soupçon de café when reading this question. You do not mention operating system, language setting or keyboard setting. The American and English keyboard have an International option which is the default on most European keyboards. This allows you to type many characters with accents directly. On my system the KEYBOARD command sets up the options. This allows me to type accents like ÇçÉéß. See below for a little more information.