Using AutoCorrect to Format Characters in a Word

When typing a some certain words I would like the characters of the words to automatically be formatted. For example, when I type LAeq I would like it to be correctly formatted as LAeq.

The solution I’ve found is to format the word, highlight the word, select AutoCorrect Options from the Tools menu, and type the word that I want to be the replacee. Also, I need to make sure that the Text Only check box remains unchecked.

I’ve come across two bugs that seem to relate to my problem, but they have been marked as fixed.
https :// and
https ://

I’m using LibreOffice Version

What you are after is AutoText. It works like this: type fn and press F3, it replaces the text with predefined snippet. You can create your own entries.

Read more: Using AutoText - LibreOffice Help

This is correct. I just wish AutoText was easier to use. The shortcut (e.g., “fn”) in particular seems difficult to set as required. I suppose the entire dialog UI will be addressed at some point because it is not the most straightforward facility.

I’m not sure Autotext is what I’m after. While it can accomplish the task, it is adding extra step to the process. If you have access to Microsoft Word 2000 or later you can see the feature I’m after. Type LAeq, put the Aeq in subscript. Select the formated text and copy it to clip board then select AutoCorrect from the tools menu. The replacee should be LAeq, and the replacement text paste in the text from the clip board and select formated text. Now try type LAeq in your document.

@Lance1 - Then it would be autoreplace with formatting, which LO doesn’t currently do. You are more than welcome to file a bug report about it, remember to mark it as enchancement request and post a link back here.

Thanks. Just having a bit more of a look at Replace - LibreOffice Help and it says, under the Replacement table section, “You can use the AutoCorrect feature to apply a specific character format to a word or abbreviation. Select the formatted text in your document, open this dialog, clear the Text only box, and then enter the text that you want to replace in the Replace box.”. The Text only box seems to do nothing for me, so perhaps its a bug and not a feature request?

You are right. Help suggest it should work, but I couldn’t get it to work either, tried quite many times and ways, nothing. So yes, it’s a bug then.

Bug 38242 and 48971 is not related to this. The settings for that is at a different place (Tools - AutoCorrect Options - Localized Options tab).

I’ve tested it and confirm this bug. Consider submitting a bug report at
Since the help file says that should work, it looks like a regression. So, include [REGRESSION] in the title. That should get more attention of the coders.

Probably related to this bug:
And this:

fdo#64699 has been marked as a duplicate of fdo#67697.

The related bug is
Bug 67697 - Autocorrect entries with formatting cannot be added


target: 4.1.3/4.0.6.

I have tested AutoCorrect Options… → Replace successfully
with LibreOffice (RC1), and LibreOffice (RC1).

Tested (e.g.) with “LAeq” → LAeq (see question).