Using extended character sets (UTF-8 and Thai)

I am new to Libre Office, but not to Office Applications.

I am running Libre Office on windows 8.1 and on Windows 7.

Using the latest (4.3) version of Libre Office Calc, I am trying to write an spreadsheet for my wife in German, English and Thai … the western languages are fine (obviously) but when I try and enter Thai into Calc, all that is displayed is the default blank rectangles.

I have enabled “Asian” and “Complex text layout” in Language Settings–>Languages.
I have set CTL to “Thai”
I have changed the Character Set in the Load/Save–>HTML Compatability options to Unicode (UTF-8)

all the above without any effect, I am still unable to enter Thai text.

How do I enable extended character sets for my documents, and enable UTF-8 encoding for them?

Many Thanks for your help.


Which font is the content displaying as squares written in?

Set the Thai to use either Tahoma, which works here, or Arial Unicode MS. The latter is a Microsoft TrueType font with a very large array of glyphs to handle a great many languages. This is why it’s usually set for the asian languages, because it does cover them (basically for anywhere Microsoft tries to sell their stuff … so that’s the entire planet). The only other font I’ve seen with a larger glyph set than Arial Unicode MS is the shareware Code2000 font, but though it is similar to Time [New Roman], it isn’t the most aesthetically pleasing font. It does, however, support overlay characters, which is pretty rare.