V7 on Windows 10 - still problems with videos

Embedded videos will not play with Impress V7 on Windows 10 Home. This is not a new problem. Actually they play correctly if you select the slide, then use Shift-F5 to start the presentation at that point. However if you start the presentation anywhere before that, the sound is OK, but only a still shot instead of the video.

If I disable Skia, I don’t even get the still shot - just a black screen.

1 Like

More information: if the slide containing the video is selected before pressing F5, then although it starts at the beginning of the presentation, the video plays OK when that slide is reached. However if any other slide is selected before F5 is pressed, the video shows the still shot behaviour.

I have put together a two-slide presentation which reproduces this every time. (I can’t see where I can attach the file to this post.)

If I remember last time this problem was discussed, it worked OK on Linux, but I’m not sure.

Same problem.

Same problem for me. Also when I do not embed the video (Insert video and select link) the same problem happens. Tried it on different computers and still the same problem. Only solution: select the slide with a video and click F5 or shift F5.

1 Like

I know it’s been a while but i just wasted a lot of time finding a solution…

Videos were working under perfectly on one system, but not on the other, both Win10.
On the second system, even the select-and-F5 trick didn’t work. Tried installing DirectShow/windows sdk and even the k-lite codec pack to no avail.
Now the first system doesn’t have an integrated GPU while the second one runs integrated intel graphics plus an Nvidia GPU.

What fixed it in the end was disabling either GPU via the device manager …

LibreOffice is now on and I no longer have any problems with videos on either of the two devices that I use. This has been the case since before this latest version. (Now on Windows 11.)

Both my Desktop and my Laptop have Nvidia GPUs.