Validity cell needs 2 right arrows to move to next cell

I came from an v6 version to V7.6.1

What I noticed is that all cells that have a validity set, I can enter data and use UP, LEFT or DOWN arrow key to move to the respectively cells. However I need to press the RIGHT arrow key 2 times to get to the next cell.

IMHO that feels like a bug.

LO 6.2.1 though it worked for me in earlier versions.
Hi would you have a small sample file would help? Here is one to see if you experience the same issue. Are your cells adjacent. Pink cells are basically unprotected to simulate normal cells and yellow are protected to show how arrow jumps A to C. In my use I had to change move selection in my particular file but arrows seem to work properly. May not fully understand your situation.

Validity Example.ods (9.8 KB)

Updated all validity cells. Used this macro SelectCellsWithValidation to check all validity cells in my sheets, and only the col D and E are validities. Problem keeps existing, also after saving the changes, reopen the file etc…

Now back to V6.4.6.2. Same sheet as it was saved above, no problems with double keys needed to get out of a validity cell using the right arrow key.

I guess I will stick with this V6.4.6.2 version.

Weird, upon the reply of @mendy I was about to create a file that shows the problem. Because of sensitive data, I was removing nearly all data, and strange enough, when I delete the data from validity columns the problem starts to disappear. Then I have removed the data and put back manually. There’s 2 validity cells per row, and after 48 rows the problem comes back.

In a brand new file, I have added similar validity columns but I not see the problem there. Maybe this is caused because the sheet is quite heavy with calculations.

If I manage to get a file that shows the problem where I can remove the sensitive data, I will post it here

file-with-problem.ods (57.6 KB)

Managed to get a minimal example… In sheet Oct at row 53 try to enter a character in column D and then use right arrow key to move to column E. Valid characters for col D are 1,2,3,4,12,21,13,31,14,41,23,32,1C,1A,L,S,CC,AE,RL,RS,C,1H,WS which can be found in Config tab.

Ubuntu MATE 22.04.3
Your file arrow key works one press and value moves to next cell.
Only thing I see which doesn’t affect the arrow is in Row 53 clicking on down arrow presents #REF! and a number of rows below present a drop down value list and #REF!. May be due to method you created sample with.
I can enter any value or click on one in dropdown and one arrow right works fine.


I am on windows 10. LO V7.6.2 now …

Indeed I have seen the same #REF! and corrected them all… in the testfile indeed I can do one right click, in my real file (with lots more data) I still face the problem needing 2 right arrow keys.

1 Like

Sorry can’t say as initially thought your test file didn’t work on your end (one arrow press). For the #REF! try selecting the cells or what I think you are setting for all the cells select the column and data/validity and set range to see if that problem persists past 48 rows. Just guessing. Delete the ranges and recreate and reset validity on a copy of file. Don’t want to lose it. On Ubuntu I can right click on file and then select Copy to Desktop. Do all my testing on it. If good file is in same location it adds copy to the filename. Use it alot.

That will take quite some time as I have 23 tabs with lots of formula’s as well. For formula’s at least you can see there’s something wrong, in validity only when you open the dropdown.

Is there any “debug logging” possibility in Calc ? Maybe I could find info in there.

Was watching TV and was wondering why use validity if in dropdown I could enter whole sentences and it would accept it. Looking closer at your sample seems you omited the check box in the validity (maybe just in sample). Attached your modified sample file with validity error checked on columns B and C.

Don’t know about the #REF! in the validity on those cells. Would seem like it wasn’t set for some reason. I tried full column and all show dropdown, yours has various versions of #REF! and dropdowns. In file used your cell range. Another thought not to do with arrow movement in copy of your file if you change/set the validity in the #REF! cells, save and reopen do they now show correctly? Or if the whole column uses the same validity select the column and set validity/save and reopen.

file-with-problem-m.ods (53.6 KB)

Do the two columns in your problem file have the same validity for each whole row like in sample. In your sample about half had issue while in file sending back used your cell range and and none with issues. Did you copy from your file? Or in ones with#REF! would you be able to figure out what cells/formulas in other sheets are referencing that column. Hard to say.