very poor font display quality

Hello folks

Comparing how LibreOffice writer and Google Docs on Chrome on a PC display the same document shows there is a major problem with LibreOffice on Windows with the default settings (Liberation Serif 12), on my computer.

I have tried turning OpenGL off, tried also taking Anti-aliasing off, but these didn’t make much difference. Some letters are touching, others have large gaps, some thick, some thin… just very, very bad.

What else can I do to fix this. I have a Nvidia GeForce GTX 970, so there should not be a problem rendering decent font quality. Your help much appreciated.


Similar questions are available on this site. It appears to be a Windows-specific issue regarding hi-dpi screens where OS zooms display at 115% or so. Search through the site for fixes (I don’t use Wondows).

I don’t use Windows

This is the best fix to 99% problems. Sorry, could not help saying it.

Hi, my screen is 100% size, 1920x1200… so pretty basic-standard…

It’s surprising and disappointing this issue has been known about for years and has not been fixed. Perhaps time to spring for MS Office or find another good free solution that can display fonts properly. I’ll look on the forum for more answers, but have not found any so far.

Windows is not the problem. LibreOffice is the problem.
Microsoft fixed all these display issues with Windows 7.
So more than 10 YEARS ago.
The LibreOffice display on Windows went backwards with the v5.3 “upgrades” which messed-up the anti-aliasing for many users.

But the biggest problem is still the lack of precision in calculating the character placement.
My understanding is calculations are done with integers and they should be floating point to get precise screen rendering.
Until LibreOffice fixes this problem font rendering on Windows is going to look like crap.
Has nothing to do with Windows.
This is 100% a LibreOffice problem.

Perhaps if it did affect Mac or Linux the devs may actually care because their screens would also look like crap.
But hey, its just the stupid Windows users …

Well @LibreTraining other than the inane and stupid comment about windows users, your comment is probably the best answer, other than to move completely away from Liberation Serif as default.

I am a Windows user.
My comment is about the attitude of some of the developers.
Mac and Linux fanatics who appear to not care about the stupid Windows users (me and you).
If the same poor display issues were happening on Mac and Linux it would already be fixed.

@LibreTraining: the problem is not Windows, MacOS, Linux or next_generation_OS, it is the availability of public information on OS internals and API. That was fine during MacOS Classic era, but now fleshy fruit company has turned to same policy as those Redmond monks. Can you imagine the myriad of FOSS developers signing systematically (and paying the fees) in their own personal names non-disclosure agreements in the hypothetical event they would need to use this information? Yes, FOSS has limits and serious disagreements. To fix the issue, can you provide reliable suite-free information to the developers so that they can circumvent the problem? If we have this bit of information and don’t share it, we are also guilty.

When I see the serious problems with the switch from X11 to Wayland (or from Cairo to Harfbuzz), I won’t throw any pebble to developers.

It’s insane that people who design a word processor haven’t been able to figure out the most basic function of a word processor in over a decade of development.

I have the same issue using a Mac. But no probplem at all with OpenOffice.

“My comment is about the attitude of some of the developers.
Mac and Linux fanatics who appear to not care about the stupid Windows users (me and you).
If the same poor display issues were happening on Mac and Linux it would already be fixed.”

I don’t want to be crass, but Libreoffice font spacing sucks on Linux too! JK. That people perceive font problems is not disputable. It’s well-documented issue. What, like half of Imgur at this point is just screens of disappointed Libreoffice writers. But it’s got nothing to do with Libreoffice. IMHO it’s all due to improper scaling on a range of diverse hardware.

“Don’t trust the zoom factor either. It says 100% but it computes a “technical zoom factor” taking into account the dpi. Therefore to get a 12pt on screen it may use a 15 pixels (= 15pt font). In principle, you won’t see the difference unless you count the pixels, but some fonts contain optimised bitmap variants for small sizes. Due to the technical zoom factor, an incorrect variant may be selected.”

This dude gets it. On Linux, installed on most common hardware like laptops with 720+ HD screens, for example, all fonts look like garbage at some pt sizes. This is because there is a specific zoom factor where the fonts will look as designed, but the software isn’t always preconfigured for optimal viewing on particular hardware. So, for example, on Linux the first thing you do after install, once you know this, is open GNOME Tweaks or whatever and fiddle with the font size OR scaling factor until you get your chosen font to render spaces between letters properly throughout the UI. The big secret with Libreoffice is doing the exact same thing.

So for the following recommended settings, you’ll want to make a new default template document, so everytime you open a new document, these settings will obtain permanently. So, open a new document. On my particular laptop, Libreoffice has the same issue people are complaining about UNTIL I set font size to an odd number like 13pt, or keep Tinos (free and better than Liberation imho) at 12pt where it’s supposed to be for most legal and academic documents, but increase the zoom factor (bottom right corner) to 125%. BAM, proper font spacing like magic. There is a different combination for every monitor I have, but easy to calibrate all things considered.

In addition to the above settings, in my experience it’s best with Tinos to turn off all built-in kerning. Go into Format → Character → Features, make sure horizontal kerning is turned off. Next go to the Position tab & make sure Pair kerning is unchecked. This is really Linux specific, but don’t let Libreoffice try to do anything to letter spacing. At this point on my hardware, fonts are absolutely beautiful, comfortable, readable, the letters consistently spaced.

Next, assuming this is still your blank document, go to File → Templates Save As → My Templates or whatever, and Save as Default. Now every new document in Writer will open to your calibrated settings. Again, these settings are for a range of typical laptops with HD+ displays that I’ve personally tested, but your own hardware may be be different. You’ll have to experiment.

I have to do the same thing under Linux with most browsers, setting the zoom factor to ameliorate font spacing issues.

I’m 100% sure this is the solution to posed question, and many similar unnecessary bug reports. Perhaps in the future some kind of automated calibration system can be implemented to avoid all this font confusion. Peace.

image description

It seems the way LibreOffice resolves fonts in windows is poor, and has not been fixed, and I have not seen any indication it will be fixed anytime soon… so replacing the default font seems to be the best way round this problem. You do this in Tools>Options>LIbreOffice Writer>Basic Fonts (Western).

Here below I have shown the most pleasant to look at 5 fonts I can find on Writer, as well as Liberation Sans and Arial for comparison.

None are perfect, most have too much space after the capital O and p for Options… but MUCH better than the default, horrible Liberation Serif.


Here is a comparison of two fonts on Libre Writer and Gdocs.

image description
image description

one could only realistically compare Times with Times, but it is clear the Gdocs is more legible and pleasant to look at. The default, Liberation Serif is worse than Times.

Is this an answer to your question? If so, make it explicit that the solution is to change font face. Otherwise, move it as en edit to your question. Others may consider, looking only from the question list, that a fix has been found. Site quality depends heavily on a rigorous use of “answers”.

I see no problem with the Liberation fonts under Windows 7. Thus, the problem may be specific to the Windows version that you use.

@gabix it would be great to see a screen shot of a paragraph of the default Liberation Serif 12 so I can compare with my windows 10 pro system… If you don’t mind, please could you post that? Cheers, Mark.

I love Libreoffice, yes really, still I cannot use it because the poor font rendering strains my eyes. Temporary users may not notice it, but I write a lot and so much wish that Libreoffice one day will get the same nice font rendering as other word processors and DTP software. Microsoft Word, Textmaker and Papyrus Author and many others look very good and don’t strain my eyes.
Even if I agree with all the complaints presented here, don’t get me wrong, Libreoffice is a great piece of software. The developers do a wonderful job (thanks a lot!) I just wish the font rendering will be fixed soon.

Attaching a screenshot. Using the answer option because can’t attach a file to a comment.

image description

Here is a screenshot at 100% zoom. Still, I can see no issue specific to Liberation Sans.

image description

OK, here is a screenshot from MS Word at 100% zoom, no big difference to me:

image description

Hi Gabix, thanks… but I am pretty sure your display on Writer is not set to 100% because your 12 point fonts are much bigger than the would be if it was 100%. The problem I see is when writer is set to 100% - see how much bigger yours are than mine in the screen grab I posted of 12 point fonts at 100%

Screenshots are not reliable to measure actual font size. It depends too much on which tool is used and saved format. JPEG will cause artefacts and may (?) shrink or enlarge the picture. PNG is acceptable (but who knows?). It also depend on screen dpi. With high dpi monitors, a 12-point optical rendering may need up to twice this size because size is converted into pixels (1pt = 1/72 " and 1pt = 1pixel on 72 dpi, but monitors nowadays are frequently in the 96 dpi range, needing a 133% zoom so that 12pt = 1/6 "). If you try to shrink/enlarge the screenshot to the real size, you cause conversion and artefacts.

sure, but a screen grab at 100% is a better starting point than none. It is also possible gabix has the same resolution as I do.