video won't play in Impress

I have searched around without finding an answer to this so I am now writing to ask for help.

I am using LibreOffice on Linux Mint xfce , version

Not sure if this is necessary, but the build is;a=log;h=144abb84a525d8e30c9dbbefa69cbbf2d8d4ae3b)

I am pasting below all my system information (most of which is probably unnecessary?).

When I use LibreOffice on a different computer, I have no problem inserting a video. But when I use it on this computer, the video does not insert properly and instead comes out looking like this (illustrated in Impress, but also happens in Writer):

When I start the slide show, the sound track is fine but the picture is black.

I have not seen this problem described in any forum I have come across but perhaps I’ve missed something.

Can you suggest what might fix this? Thanks!


system information:

System: Kernel: 5.4.0-73-generic x86_64 bits: 64 compiler: gcc v: 9.3.0 Desktop: Xfce 4.14.2
tk: Gtk 3.24.13 wm: xfwm4 dm: LightDM Distro: Linux Mint 20.1 Ulyssa
base: Ubuntu 20.04 focal

Machine: Type: Portable System: Dell product: Inspiron 7720 v: N/A serial: Chassis:
type: 8 v: 0.1 serial:
Mobo: Dell model: 04M3YM v: A00 serial: UEFI [Legacy]: Dell v: A13
date: 03/11/2013

Battery: ID-1: BAT0 charge: 22.2 Wh condition: 22.2/48.8 Wh (45%) volts: 12.4/11.1
model: SIMPLO Dell serial: status: Full
Device-1: hidpp_battery_0 model: Logitech Wireless Mouse M185/M225 serial:
charge: 100% (should be ignored) status: Discharging

CPU: Topology: Dual Core model: Intel Core i5-3230M bits: 64 type: MT MCP arch: Ivy Bridge
rev: 9 L2 cache: 3072 KiB
flags: avx lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 20751
Speed: 2993 MHz min/max: 1200/3200 MHz Core speeds (MHz): 1: 2454 2: 2884 3: 1999
4: 2410

Graphics: Device-1: Intel 3rd Gen Core processor Graphics vendor: Dell driver: i915 v: kernel
bus ID: 00:02.0 chip ID: 8086:0166
Device-2: NVIDIA GK107M [GeForce GT 650M] vendor: Dell driver: nvidia v: 390.143
bus ID: 01:00.0 chip ID: 10de:0fd1
Display: x11 server: X.Org 1.20.9 driver: modesetting,nvidia
unloaded: fbdev,nouveau,vesa resolution: 1920x1080~60Hz
OpenGL: renderer: GeForce GT 650M/PCIe/SSE2 v: 4.6.0 NVIDIA 390.143 direct render: Yes

Audio: Device-1: Intel 7 Series/C216 Family High Definition Audio vendor: Dell
driver: snd_hda_intel v: kernel bus ID: 00:1b.0 chip ID: 8086:1e20
Sound Server: ALSA v: k5.4.0-73-generic

Network: Device-1: Intel Centrino Wireless-N 2230 driver: iwlwifi v: kernel port: 3000
bus ID: 02:00.0 chip ID: 8086:0887
IF: wlp2s0 state: up mac:
Device-2: Realtek RTL810xE PCI Express Fast Ethernet vendor: Dell driver: r8169
v: kernel port: 2000 bus ID: 03:00.0 chip ID: 10ec:8136
IF: enp3s0 state: down mac:

Drives: Local Storage: total: 931.51 GiB used: 236.49 GiB (25.4%)
ID-1: /dev/sda vendor: Seagate model: ST1000LM024 HN-M101MBB size: 931.51 GiB
speed: 3.0 Gb/s serial:

Partition: ID-1: / size: 27.54 GiB used: 15.63 GiB (56.8%) fs: ext4 dev: /dev/sda13

USB: Hub: 1-0:1 info: Full speed (or root) Hub ports: 2 rev: 2.0 chip ID: 1d6b:0002
Hub: 1-1:2 info: Intel Integrated Rate Matching Hub ports: 6 rev: 2.0
chip ID: 8087:0024
Device-1: 1-1.3:3 info: Realtek RTS5129 Card Reader Controller type:
driver: rtsx_usb,rtsx_usb_ms,rtsx_usb_sdmmc rev: 2.0 chip ID: 0bda:0129
Device-2: 1-1.5:4 info: Microdia type: Video driver: uvcvideo rev: 2.0
chip ID: 0c45:644b
Hub: 2-0:1 info: Full speed (or root) Hub ports: 2 rev: 2.0 chip ID: 1d6b:0002
Hub: 2-1:2 info: Intel Integrated Rate Matching Hub ports: 8 rev: 2.0
chip ID: 8087:0024
Device-3: 2-1.5:3 info: Intel type: Bluetooth driver: btusb rev: 2.0 chip ID: 8087:07da
Hub: 3-0:1 info: Full speed (or root) Hub ports: 4 rev: 2.0 chip ID: 1d6b:0002
Device-4: 3-4:2 info: Logitech Unifying Receiver type: Mouse,HID
driver: logitech-djreceiver,usbhid rev: 2.0 chip ID: 046d:c52f
Hub: 4-0:1 info: Full speed (or root) Hub ports: 4 rev: 3.0 chip ID: 1d6b:0003

Sensors: System Temperatures: cpu: 74.0 C mobo: 52.0 C gpu: nvidia temp: 67 C
Fan Speeds (RPM): N/A

Repos: No active apt repos in: /etc/apt/sources.list
Active apt repos in: /etc/apt/sources.list.d/official-package-repositories.list
1: deb http: // ulyssa main upstream import backport
2: deb http: // focal main restricted universe multiverse
3: deb http: // focal-updates main restricted universe multiverse
4: deb http: // focal-backports main restricted universe multiverse
5: deb http: // focal-security main restricted universe multiverse
6: deb http: // focal partner
Active apt repos in: /etc/apt/sources.list.d/spotify.list
1: deb http: // stable non-free

Info: Processes: 229 Uptime: 6h 49m Memory: 5.67 GiB used: 3.38 GiB (59.6%) Init: systemd
v: 245 runlevel: 5 Compilers: gcc: 9.3.0 alt: 9 Client: Unknown python3.8 client
inxi: 3.0.38

Maybe it can help you:

Thanks for those suggestions. I’ve tried what I can from those but haven’t solved the issue. Some of the packages listed don’t seem to be available in my distro, at least they are not listed in synaptic package manager.

I have the same problem.
Libreoffice 7.4.5
OS: MInt 20.3; Linux Kernel:5.4.0-139-generic .
I have a integrated Intel grafic. Intel Corporation 4th Gen Core Processor Integrated Graphics Controller There it works with video.
And I have an Nvidia. NVIDIA GeForce GTX 950M
With this Grafic card it alway crashes.