Wavy Words in Writer


Not always, but sometimes words become like this. As if they are wavy.
What is the reason and is it a bug?

It seems as a rendering related problem. If the wavy state is appeared again, when you refresh the screen content (by scrolling some page up and down), or reopen the document, then it is some other issue.
If it is really a rendering problem, then trty to change something in the display settings (for example Skia on/off inside LO, or some others in the driver in the op. sys.).
Please upload a sample file here.

1 Like

It is strange!
There is not “Skia” option in my settings!

Which version of the LO are you using?
What operating system are you using?
My LO 6.1.6 uses the OpenGL on Win 10, and my LO 7.4.2 uses the Skia.

Version: / LibreOffice Community
Build ID: 40(Build:3)
CPU threads: 2; OS: Linux 5.15; UI render: default; VCL: gtk3
Locale: fa-IR (en_US.UTF-8); UI: en-US
Ubuntu package version: 1:7.4.2~rc3-0ubuntu0.22.04.1~lo1
Calc: threaded

Sorry, I have not Linux for the daily work. Try to change the exsting options…

It also happens from time to time in my Fedora Linux, LO when text is scrolled up. It looks like the rendering does not remember exactly how the existing text was positioned on screen and new text is offset one pixel. I don’t remember if I switched to another application and went back to Writer. It may be a result of integer arithmetic rounding.

Anyway, just scroll a bit so that the faulty line is sent off-screen and scroll back.

1 Like