:---: (weird problem with em dash shortcut that stops working)

Hi, so I have been using Libreoffice Writer for a couple of years, but I’m not tech savvy so one of the issues I have is using em dash, meaning this: —

I often just copy/paste, but someone said a shortcut works where if you type in :—: then it automatically creates an em dash.

My problem is that this shortcut works then stops working. The way I get it to work again is by going to Tools/Language/For All Text/English (USA). When I do this, it usually begins working again. I don’t understand why choosing language should have anything to do with the shortcut working.

This is how it is designed: when you create an autoreplacement entry, it is language-specific by default. If you want it to work for all languages, choose, respectively, [All] in the language selector in the AutoCorrect dialog.

What @gabix says. Automatic replacement needs to be language-specific. E.g., it makes sense to automatically replace standalone “i” with “I” for English flavors, but not for other languages. Note that Autocorrect replacement entry is not a shortcut, but a text you type to the document which appears on the page, then analyzed and replaced (e.g. to fix common typos, or provide convenience like with :---:).

Your shortcut is an autocorrect entry. Autocorrection entries connect to language settings.

For stuff you need to use in all languages (I would say, for all “shorthand” purposes), use autotext instead.

Note that at the time of writing, this online help entry (click “autotext” above) may be a bit dated. The “fn” and “dt” defaults mentioned there are not “preloaded” in all versions of the suite.

both fn and dt work e.g. in and current master (and I use at least the latter every day) …