Weird specific crash, not user profile problem

So I’m having this problem where every time I open a previously saved document in Writer to continue working on it it crashes after a few characters are typed. It seems to be a specific character that’s typed (just the letter ‘i’ in bold and underlined, if that makes any difference) that causes it to crash but I honestly have no idea. I tried it on a couple other documents and I could type some random stuff but when I typed that phrase I was trying to add to the first document it crashed.

I’ve restarted my computer, updated LibreOffice, started in safe mode to see if it was a user profile issue, tried deleting the recovery data and trying without doing that, nothing’s helping. This has happened before a couple months ago and I just had to give up and leave it for a couple days and it was fine when I went back, but I really don’t have the time for that as this is for an assignment, plus I don’t want to have to rely on an unreliable platform. Any idea what could be causing this? I’ve also scanned my laptop multiple times for any viruses, malware, etc. and there’s nothing there.

Edit: I don’t have a ‘Zillion’ laptop, just an Asus laptop running on standard Windows 10. Nothing with any kind of differently formatted keyboard/primary keys/etc.

Your laptop is Zillion ZZ30 with a 6502 processor under MarvelOS 3.14 and you’re using LO 2.718. You’re lucky. We’re millions to use the same computer in the same configuration.

Read these guidelines and edit your question (don’t use an answer, this is not a forum site) to provide technical facts.

“letter ‘I’ in bold and underlined” is probably a primary key on your Zillion ZZ30 keyboard, but not on mine. What sequence of commands fo you use to get this formatted letter on common keyboards?

I’m confused, I don’t have that laptop? I have an Asus laptop, I genuinely have no idea what you’re talking about.

@starstark: this was sarcastic irony as you didn’t provide any technical data. I couldn’t guess because my crystall ball is in the shop for maintenance.

FYI, there is no such “standard Windows 10”. Every computer is customised, at least regarding the installed upgrade patches and applications. An “updated LO” doesn’t tell us its version number.

That said, how do you type your “bold underline I”? Changing a character or paragraph style? Or typing Ctrl+ B, Ctrl+U, I? Pushing the toolbar buttons before typing I?

This is important because we aren’t standing behind you while you work.

You don’t have to be rude about it, it’s not like there’s a rule when you post that asks you to specify every single thing about your computer. Not everyone is super into PCs lmao. I just use crtl+b and ctrl+u and there’s never usually a problem with it. I’ve typed out the exact same thing countless times into other documents and it’s been fine. It’s LO version 6.5. Calm down.

Once again, you are not accurate (have you read the guidelines?). If the problem is in LO, it is important to identify the release to see if patches have brought in regression. To the best of my knowledge, the latest stable version is

An important “detail”: is your document saved .doc(x) (Word compatibility mode) or .odt (native format)? Has it a complex structure (many formatting changes, illustrations inserted, tables)?

Does the problem occur inside a nested object like a table or a frame?

The problem is most likely a corrupted Writer document. If you select all and copy then paste into a new writer document does the issue persist?