What controls white background of Writer document

Text I pasted from the web has a white background. (I usually work with a dark document background, so I can easily see that it is white.)

I can’t figure out what controls the whiteness. It doesn’t appear to be controlled by styles or direct formatting.

I know I can prevent this problem by simply pasting the text without formatting but I want to understand what is happening.Calc release notes sample.odt

I see no dark document background; how is your background set and to what?

@robleyd: OP refers to Options-LibreOffice-Application Colors-Document background.

I thought that might be the case but asked the question as I have been censured here previously for making assumptions about people’s actions.

Robleyd, I appreciate your wanting to be careful about making assumptions.

This is the (innermost) section in your document that has the white background; what’s more is that inspecting it, it shows “No fill” set in its property. But setting the section’s background to some solid color, applying it, then setting it back to No fill makes the background disappear.

The wrong initial color in the dialog must be a bug. Submitted tdf#121186.

Thanks for checking into this and submitting the bug. “It affects me, too.” I use a “sepia” background in all my LibO apps (mostly Writer, sometimes Calc) and had noticed the “pasted white” BG often … but was too lazy to do anything about it!

Thank you so much for looking into this, Mike. I am glad to hear that this revealed a bug that others have seen and that there is an easy work-around.