What happened to my toolbars?

I upgraded my system to Fedora 21 and Libreoffice was also upgraded to version as part of the upgrade. When I tried to open and use an existing database, I got a lot of errors that didn’t make any sense as to what was wrong. I tried to search for an answer but could not find one. I went to the LO web site and saw that version was available as a download. I downloaded it and installed it. When I tried to open and create a new text document the toolbar icons are really messed up.

Here is a screenprint of the toolbar area. What is going on?

Thank you

p.s. Yes - that is what the toolbar looks like.

I would do the following and in the outlined order:

1 - Reset my user profile. For details please refer to: https://wiki.documentfoundation.org/UserProfile

2- Go back to LibO 4.3.6

It looks from the provided screenshot like it may be bug tdf#89613. The artefacting seems to predominantly affect KDE systems using the Oxygen theme but is possibly related to the OpenGL changes in v4.4.