What should I do about Writer 5.4 crash?

I am trying to index a book-length file. I have inserted the index entries. I went to the end of the book, inserted a page break, and went to Insert | Table of Contents and Index | Table of Contents, Index or Bibliography. I selected Type | Alphabetical Index. I changed the title to “Index” and clicked OK. Writer crashed with this error message: "LibreOffice 5.4- Fatal Error. Invalid vector subscript. I’ve tried all the usual stuff–rebooting, making sure no other LibreOffice files were open, trying it without the page break. Each time it crashes.

Should I uninstall and load version 5.3.7? I need to get this index done promptly. What’s the shortest path between here and making that happen?

Also, do you need me to report the bug?


Take a look at this bug: tdf#113873. I would never hesitate to check Bugzilla for problems of this sort.

You didn’t give your minor version of 5.4.x, but it sounds like the problem is fixed in 5.4.4.

I tried, and the problem seems to be fixed. Thanks.