What's been going wrong? Where can I obtain help? PLEASE!!!

LibreOffice 3.5 (English version) ‘Writer’ (I presume.)
Operating system…(English) Microsoft

For the past two-four weeks or so (indeed, including a spell around May 2013 also) I’ve been encountering what can surely only be various ‘gremlins’ (computer viruses/bugs/scam-artists’/hackers’ handiwork) in my LibreOffice ‘system’…causing me endless frustration, wasted hours and effort etc etc etc…

The ‘messages’ (in response to my numerous and at times rather creative attempts to access my various LO documents - extremely important to this lay/freelance writer/blogger) are ‘bamfoozling’ and ‘boondoggling’ (to be mild about it), and have included such ‘advice’ as ‘the (my particular) file (in question) is corrupt and therefore cannot be opened…[possibly] the result of document manipulation or of structural damage due to data transmission’…and, so. apparently, ‘execution of macros is disabled for this document’, and is, otherwise, simply ‘locked for editing’; occasionally, offering me (later on) the options of read-only ‘opening’ of said document/s.

Alternatively I am informed that ‘Either another instance of LO is accessing your personal settings or your personal settings are locked’, with warnings that 'Simultaneous access can lead to inconsistencies (in such settings) and advice that I should ‘make sure user closes LO on host’ (sic).

Hey, what the heck am I to do, apart from pulling out every remaining hair (on my head and beard)?

Every time I’ve (inevitably unsuccessfully) sought to retrieve said documents via ‘opening’ my documents in my various system files, I’ve subsequently/immediately encountered numerous ‘lock.doc’ versions of each original document. Indeed, a little while ago (on Easter Monday) I even discovered that each time I re-accessed all manner of other files in ‘My Documents’ (even just ‘simple’ jpeg photos), essentially for each and every such re-accessed document an additional ‘lock.doc’ version of such was/is created…!!! (Obviously one can only assume my very system itself has some kind of self-replicating bug/virus contaminating ANYTHING AND EVERYTHING I seek to re-access…

HELP ME PLEASE…I’m rapidly approaching a breakdown I believe…

Yours Sincerely

P.S. Am a little confused now as to which of my (two, marginally variant) passwords for your site is now the one for me to use, as, through my typical technical inexpertise, I’ve just before had to ‘rework’ that pw to get back onto your site just now, and yet my original password still appears at the top of this ‘entry page’.

What follows I write typically as a comment but I want to explain you a bit more; thus an answer.

Please, help the helper to help you and provide technical information.

I understand that you are frustrated and as such spill out your emotions. However, this does not help you because nobody in this forum can help you based on what your wrote.

OS: XP, Vista, W7, W8. W8.1 ???
LibO version: " I believe " does not help. Please look for the exact version.

As you mentioned a virus, which you suspect to be in LibO, please first use an updated virus checker and make sure your Windows PC is clean. Windows is very vulnerable for viruses and other bad stuff.

Once you know your PC is clean. Describe in details what you do in LibO and what the result of each step is. Keep in mind that people who want to help you need often to make a simulation to understand your problem. Thus, please so kind and provide technical information.

Thanks ‘Whoever’ (since you seem to have no name). Yes, all that you say may well be true etc etc etc. And I accept that more info could well be useful. Still, we all have only so much time and money (e.g. to pay for all those various upgrades, in many instances), and so, at this stage I’ll pursue HTH’s suggestion and see how that works out. But if it fails I’ll need to pursue things further as you suggest. Thanks for your advice, though, it’s all good…


I have had both .ods & .odt documents go “corrupt” on me with great regularity since v 4.4.

I thought it might be because of BTSync across boxen or SyncBack backups among other devices but with all those disabled I was still losing shit left & right.

After losing all MY hair looking online I tried this in desperation and it worked. To wit: rename the un-openable file from “.ods” to “.xls” and try again.

In other words just reclassify it as the MS equivalent and open it as that. I then re-save in the open format.

This has worked on Win7 and Mint Linux system versions. I do not have MS Office installed on any system.


Thanks Muchly HTH - will see if that works…Good to know I’m not alone in my quandary!
Sounds a promising approach, similar to what I had to do to get a blogsite up and operating properly again…all about the way the/my ‘system’ happened to read what I’d written/composed.