What's the base unit for LibreOffice Writer?

What’s the base unit that Libreoffice uses for text in stylesheets? It doesn’t seem to be points. Should I design in millimeters? inches, so that the math stays true?

When I create a style sheet, the values that save don’t match what I entered, and I can’t figure out why.

When I correct these values in the stylesheet directly, then load and resave, they’ve reverted to the ‘not-quite the same’ value.

<style:paragraph-properties fo:margin-left=“0.99pt” (typed in 1pt)
fo:margin-right=“2.01pt” (typed in 2pt)
fo:margin-top=“4pt” (typed in 3pt)
fo:margin-bottom=“4.99pt” (typed in 4pt)
fo:line-height=“11.31pt” (typed in 11.3pt)
fo:text-indent=“3pt” (typed in 3pt)

I’m counting on being able to do math in a LOCalc sheet to create a well-formed stylesheet and have a column with no footnotes end at the same edge that a column with footnotes ends. That is, that ‘register-true’ should results in the text flowing to the BOTTOM of the page (not the bottom of the page minus 3/4 a row of text), so that bottom aligned footnotes (which aren’t 'register true because they are 20% smaller) optically end on the same row. I already use this method for Calc->Indesign. But the random return values are real… mathematically accurate designs have random factor that results in gaps between columns with footnotes and no footnotes.

LO 6.0.5 MacOSX 10.13 if it matters.

If it’s any consolation, I’ve also found that many web browser engines have similar slight rounding issues with layout. And also there are slight differences between Chrome and Firefox for example. I imagine that it’s a trade-off between speed and accuracy. I also know that it’s possible to get the underlying math right, but it does take careful attention from the developer’s to the internal calculations, especially when division is used.

This is a bug in LibreOffice due to internal rounding errors.
I too have tried to create precise layouts in Writer like I do in InDesign or QuarkXPress.
Set all my measurements to points and then tried to get it all to work properly.
Same result as you - the entered measurements keep changing.
Annoying isn’t it.

There are several bugs links I have saved regarding this issue, but most of them point back to this one.
Bug 44267 - Two decimal digits are insufficient for specifying object position and size

So the issue appears to be simply not enough internal precision is used to get exact measurements right.

I gave up on trying to use Writer to create high-end publication documents with precise layouts.
Currently it is just not possible.


This is only a minor bug. It’ll drive me nuts, but will be invisible in the printed works. I’ll just force registered text (I do anyway.)

The bigger “bug” is a lack of “ignore punctuation” or “punctuation aware” full justification. That’s very visible. I have a fix, but it’s a kludge, and only works on column starts. but that’s 99% of the visibility.

The only other gotcha I’ve run into is a lack of “chapter drop caps” on very short paragraphs. Another workaround, but it works well.