When Appending a price the value is shifted

I created a table where one of the columns is UnitPrice and it is set as type decimal with 2 decimal places. When I copy a calc file and append the data to my table the unit price is shifted by 2 decimal places. My steps are as follows:
1 Select the data
2 Right-click on my table a do a paste
3 Under “Options” I select the radio button “Append data” with nothing else checked
4 Under “Assigned Columns” all are checked and the first line looks correct (the unit price shows 1.58)
5 After clicking create and opening the table the unit price shows 0.01

If I create the table and make UnitPrice a decimal with 1 decimal place the 1.58 comes out as 0.1 after appending.

How do I append a column of prices without the value being shifted?

Thank you


Have just tested using Mint 18.3 & LO v6.1.3 and see no problem. Used different formats in Calc & both decimal & numeric fields in Base using default HSQLDB. The was no shifting. Used same steps you presented. Tried at least five times with varying figures. All worked. Please supply LO version, OS & type DB you are using.

Bottom line of opening Base screen should specify DB being used.

I’m using LO v6.1.2.1 with Windows 10 ~ the database type is Firebird

Please do not post as answer unless it is to answer the question asked. Instead use add a comment or edit question and add information noting the edited information.


Information, more so in Base, is important in determining where the problem lies. In this case it is the database being used. Your information is still not clear as Firebird can be the embedded version or you can be using Firebird server. In light of that I tested both (although I really didn’t need to as I knew the probable answer).

Using Firebird server there is no problem. It transfers the data without a problem. However using Firebird embedded (Base default when Enable experimental features has been turned on, has a number of open bugs. Here are a few which are related:

Bug 118043 - Firebird: Migration Data loss (change) when moving decimal datatype data defined in HSQL schema

Bug 116893 - Firebird - Error when transferring/pasting NUMERIC or DECIMAL table data

Bug 53027 - EDITING: dBase-Import-Wizard fails when trying to append DECIMAL(NUMERIC) and BOOLEAN data types

My tests also show what you are seeing and this is because of existing bugs. Bug #118043 above does state something to be fixed in v6.2 but have seen no results yet in this version.

I created an HSQLDB Embedded database and I was able to append the unit prices without having their value shifted. I tried getting into the Firebird Embedded database and unchecked “Enable experimental features” but I had the same problem of the unit price getting shifted when I appended the data.

So I gues I have to use the HSQLDB database.