When dragging a LibreOffice app, it minimizes it to 1 pixel

When I drag a LibreOffice app, for example Calc (I grab it from the system menu bar at the top where it shows the name of it), it shrinks down to just a line, a 1 pixel width thing. This has been happening for the past 3 years at least but I thought it would be fixed on Ubuntu 22.04 with the new LibreOffice. It is still happening. At the bottom is an image of it. Hopefully a solution about not changing or resizing it while dragging could be implemented, or a “minimum resize size” rule.

LibreOffice Version: 7.3.5.2 (Ubuntu 22.04)

image

…with the new LibreOffice.

Which new?
Download LibreOffice | LibreOffice - Free Office Suite - Based on OpenOffice - Compatible with Microsoft

or other?

Updated question to include LibreOffice 7.3.5.2

1 Like

I have the same problem. It was also in 6.4 and now in 7.3

Opening libreoffice in full screen. Drag it and it is minimized to 1 pixel in width as mentioned.

Same here. Dragging any Libreoffice app, resizes to a 1px window
daniel@med030  ~  lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 22.04.2 LTS
Release: 22.04
Codename: jammy
daniel@med030  ~  gnome-shell --version
GNOME Shell 42.5
daniel@med030  ~  libreoffice --version
LibreOffice 7.3.7.2 30(Build:2)

1 Like

In Ubuntu, switch to the window with Alt+Tab then press Alt + → which (if you have more than one window open) will cycle through them. Release the keys when you have the app selected. You can then resize using the arrow keys. If all you have still is the collapsed version, click on what you can see of the top bar and select Resize and using the arrows keys size the window as required. Then Press the left mouse key when done resizing.

In cases where you still only see an extremely small window, you should be able to locate the mouse pointer on one of the corners in such a way that the cursor changes shape to indicate you can resize: . Drag, and you see you can stretch the window to a decent size.

Then ctrl+S to save not just file entries but how the file is presented as well on future occasions.

An alternative to try is to open Libreoffice in the terminal and select Calc Spreadsheet from the left panel. This should open calc in full screen mode. After it’s opened, double click on the top bar of the app (to minimise it) and then close the app and close terminal. Next time you select Calc from the dock, it should open minimised.

Note that holding / not releasing the Alt key in between is necessary for that to work. Another shortcut for switching between an application’s windows is Alt+` (whatever key is above the Tab key in a keyboard layout thus memorable) which contrary to Alt+ → also works when an application window is already focused.

1 Like

It’s a “feature” of GTK3 and GTK4 with Wayland.
The solution:

  1. install gnome-tweaks,
  2. GnomeTweaks → Windows → Attach Modal Windows → uncheck!

Um… are you sure you wanted to present that as a solution to this problem? That helps if modal dialogs can’t be moved and obstruct the current application window.

Yes, grabbing a modal dialog window in LibreOffice shrinks the underlying main window to minimal size.
Try for example in Calc: start creating a new chart and move the dialog: the whole Calc window shrinks. Since LibreOffice has many modal windows and components, moving anything shrinks the main window.

Just tried and couldn’t reproduce, the entire application window moves along with it. LO 7.5.7 and 7.6.3.0.0+ on Fedora F38.

Are you using Wayland and GTK3 or 4?
If not, may be difficult to reproduce.

Wayland with LO default GTK3 backend.

I can reproduce on a fresh install of Kubuntu 23.10 using wayland and kf5 backend. So I reckon it´s not a GTK / Qt bug but a LO one.

One difficult thing is that it´s not consistent and only happens sometimes, so it´s hard to provide the exact steps to reproduce. It´s rather annoying though! To me it happen either on drag or resize.

Is there a bug report opened about this?