When I open LibOffice, NO recent files are listed

I can’t find the setting to make them appear. They have been missing for months, through the last several updates. They are on other computers in my home of the same style and work perfectly. Can someone give me guidance?

The most recent documents are represented by little preview images in the main area of the LibO window after startup for a long time now. The tool ‘Recent Files’ in the side panel only preselect6s the first item then and is of no use, IMO.

A list of recent files you should get via > ‘File’ > ‘Recent Documents’ (keyboard: ‘Alt’ > “f” > “u” for English UI). If not, tell what you actually get, please.

Maybe is launching directly one of the LibreOffice applications?

Alt - f - u shows “NO Documents”.
I have the current version of LibO, and I used to see the recent docs, but this computer suddenly stopped showing them. My other computers are all working fine with LibO.

Please try resetting the user profile, sometimes solves strange issues.
Usually it’s enough renaming/deleting the file “user/registrymodifications.xcu”, it affects all the options in Menu/Tools/Options, and the files “user/basic/dialog.xlc” and “scrip.xlc” are overwritten, additionally custom colors in “user/config/standard.soc” are lost.

Yes resetting the profile worked …like a charm !
My history is back up and running.
click here for instructions

Number of recent files shown is controlled by the expert configuration property /org.openoffice.Office.Common/History PickListSize (see help). Check that you don’t have 0 there.

I went to “advanced configuration” and did a search for what you show in red. The search came back empty. What is the next step?

You also need to activate ‘Excpert configuration’. There is a line for entering a search string.
Try PickListSize and nothing else. You will get exactly one hit. Choose the property / Edit / enter new value (30 e.g.) / OK./ OK. Done