When I try to save in calc as an xls/xlsx file, it saves instead as an ole2 file. Other formats seem to work. I have tried reinstalling

Wattos 16.04 (basically a stripped down version of Lubuntu), 32 bit system.

Found the answer. I must have somehow accidentally unchecked the “automatic file extension” box in the “save” dialog box. When I checked the box, everything was back to normal. Never knew it would automatically save as “Ole2” with the box unchecked… you learn something new every day! Sorry for the inconvenience!