Whenever I type 1st/2nd/3rd/etc, Libreoffice capitalizes the center number.

Whenever I type 1st/2nd/3rd, the second letter is capitalized, 1st to 1St, 2nd to 2Nd, 3rd to 3Rd, etc.

This is after using Tools>AutoCorrect>AutoCorrect Options…>Localized Options, and then unclicking “Format ordinal numbers suffixes (1st → 1^st)” under both [M] and [T] to prevent it from modifying ordinal numbers.

I’m using Windows 10. and LO (x64)

Update: After some testing, I have found that this error happens when I type the ordinal after the tab key is used.

How can I fix this?

Which version is that?

In which component does this happen? You tagged common. You should have tagged writer, calc, draw or impress. Please retag for the used app. Press Enter twice to exit tag mode.

Edit your question to improve the description. Mention OS name and LO version.

This site is not a forum but a Question & Answer type. There is no conversation. Answers are reserved for solutions, so, please, edit, not “Add Answer”.

First, I need an explanation of what is what. Common, writer, calc, draw, and impress don’t indicate anything to me and I do not understand what connection they have with auto-correct errors.

Common sounded the most relevant because, common? Writer? I’m not writing anything. Calc? This is not a calculation. Draw? This isn’t art, and impress? What even is impress?

I’m using Windows 10. and LO (x64)

"So, please edit, not “add answer”

I don’t follow. Do you want my to type “Add answer” to my question?

Common, writer, calc, draw, and impress don’t indicate anything to me

Heh, this site is about LibreOffice, and LibreOffice consists of several components: namely, Writer for working with text document, Calc for spreadsheets, Draw for drawings, Impress for presentations, Math for formulas, Base for databases. You may see them as shortcuts in main menu of your OS; in LibreOffice Start Center’s left panel; in documentation, etc. It seems reasonable to expect users of the site to understand that when a writer tag is used, it’s supposed to mean “question related to work in Writer component”, and “common” means “a problem that happens in many components”…

I don’t follow. Do you want my to type “Add answer” to my question?

That was meant to tell you that you should not use the “Add Answer” box below, that is reserved for solutions, but instead to use “edit” button in the question itself, and add missing information right there into the question, since it’s essential part of the question.

Use of “Add Answer” to provide more details to the question is a common mistake of newcomers, hence advanced users of this site try to help newbies to not do the mistakes, telling how to do things properly.

I see. How do I retag the document. I tried pressing retag. and changing it, but when I type in writer, a drop box comes up with words including writer in it, but not writer itself. Can’t quite figure out how to actually select writer as opposed to the rest. The program will not let me select anything outside of what is in this dropbox.

Okay, reformatted, I think. I really don’t know what setting is causing this. I just updated both Windows 10, and to the latest version of LibreOffice, and it’s still producing the same error.

To fix this issue, go to Tools>AutoCorrect>AutoCorrect Options…>Options, and uncheck [T]: Capitalize the first letter of every sentence.

I believe this may be a glitch. The system seems to be interpreting the first letter of the ordinal as the first letter in a sentence, forcing it to capitalize.