Where does LO store keyboards/shortcuts?

Okay, I think I know where I went wrong with the keyboard fiasco, but I need help setting it right. The reason my navigation arrows and backspace stopped working might be that when I tried to create shortcuts to accented vowels, I saw the “load” button and thought it meant that I could create a file with each letter ad load it in for each designated shortcut. So I made a “Special Character” file for these. But now I think that Libre Office thinks that’s where to store keyboard configurations, but can’t tap into it, so all of the shortcut keys have disappeared–including basic navigational keys like the arrows.

The question is, where is the right file location, and how do I get it back? Or am I barking up the wrong tree?

This is rather urgent as I’ve got a deadline in the balance, on 8/21.

This question is a follow-up of → My Navigation Keys Quit.

Customized keyboard shortcuts are stored in your LibreOffice user profile,
configuration file "registrymodifications.xcu",
path "%appdata%\LibreOffice\3\user\registrymodifications.xcu".

Backup the original file "registrymodifications.xcu".

Open the file "registrymodifications.xcu" with a text editor.

Search for keyword "Accelerators".

Remove all entries, beginning with:

<item oor:path="/org.openoffice.Office.Accelerators/...>...</item>.

Save the file.

That should restore the default values.

Sample 1

<item oor:path="/org.openoffice.Office.Accelerators/PrimaryKeys/Global">
 <node oor:name="U_MOD1" oor:op="replace">
  <prop oor:name="Command" oor:op="fuse">
   <value xml:lang="en-US">vnd.sun.star.script:Standard.Module1.paste_unformatted?language=Basic&location=application</value>

<item oor:path="/org.openoffice.Office.Accelerators/PrimaryKeys/Modules/org.openoffice.Office.Accelerators:Module['com.sun.star.text.TextDocument']">
 <node oor:name="8_SHIFT_MOD1_MOD2" oor:op="replace">
  <prop oor:name="Command" oor:op="fuse">
   <value xml:lang="en-US">.uno:StyleApply?Style:string=d_fr&FamilyName:string=CharacterStyles</value>

Sample 2

Sample 3

Thank you and bless you! I will try this immediately!

Nope. It still does not work. Something else must have gone wrong.

Nothing I do works. None of the shortcut keys work. I don’t know what to do, and apparently nobody else does, either. I’ll have to find some other program, I guess.

You may try:

  1. Close LibreOffice (+ Quickstarter, if enabled)
  2. Rename "registrymodifications.xcu" to "registrymodifications_old.xcu"
  3. Restart LibreOffice
  4. Menu File → New → Text Document
  5. Type some text
  6. Check the shortcut keys.

Have you found any 'item oor:path=/org.openoffice.Office.Accelerators/...' in your original "registrymodifications.xcu"? — Have you closed LibreOffice (+ Quickstarter) before editing your original "registrymodifications.xcu"?

@manj_k – I guess we won’t meet the 8/21 deadline here… Thoughts on what we should do with this question? Your Answer is very detailed…