Where to put my custom palette in

In 6.2.0, I made a (huge) custom palette .soc file and got it to work by copying it into /opt/libreoffice6.2/share/palette
Now in (THANK YOU THANK YOU ALL!!! It is fantastic!) I want to use the same palette, but it doesn’t show up as an option. Can someone tell me what to do? Thanks again!

by the way, I’d be happy to send it to you in case you might like to use it–it has colors in order, hues in different columns, going from pale to light to bright to darks, with logical names and the css label as well

I have tested on my Linux (OpenSUSE Leap 15) to put a .soc file into directory /opt/libreoffice6.2/share/palette and it worked like a charm.

Build-ID: 2b840030fec2aae0fd2658d8d4f9548af4e3518d
CPU-Threads: 8; BS: Linux 4.12; UI-Render: GL; VCL: kde5;
Gebietsschema: de-DE (de_DE.UTF-8); UI-Sprache: de-DE
Calc: threaded

My testfile was from Farbpalette erstellen - The Document Foundation Wiki, where there are two example files My_*.soc (for English scroll down)

I did another test and it could be a permission problem. Please check whether your .soc file has -rw-r--r-- If the user has no read permission, the palette will be shown in the dialog but looks like having no colors defined.

Thanks for responding. My palette has the same -rw-r–r-- permissions as all the other palettes, and they all show up. It worked perfectly in 6.2.0 for me also, it’s only since I upgraded to from the Ubuntu repositories that my palette doesn’t show up. I even copied the first several lines of coding from the new palettes, since there are a few extra xmlns there, but it still doesn’t show up in a document.
I think it’s looking in a different location, because I copied a palette file to “another.soc” and “another” doesn’t show up in the document palette menu. Do you know if these palettes exist in another directory somewhere?

I found the pallette files in /snap/libreoffice/112/lib/libreoffice/share/palette (current). So far can’t write there, even as root; Read-only file system. The directory has drwxr-xr-x so I think it should be writable by root … to the best of my understanding.

OK - that’s all beyond my understanding of ubuntu, its repositories, the /snap loop devices and their purpose (but they are not the installation directories of software, and are not writeabe - even not by root - since they are mounted ‘readonly[ro]’)

Thank you for replying–I don’t understand snap/ubuntu either, I just found libreoffice palettes in that directory. So these are not the installation directories–is opt/ the installation directory? Anything I can do to get to see my custom palette? Thanks ever so much!

LibreOffice downloaded and installed by terminal sudo dpkg -i *.deb, or gdebi, puts libreoffice6.2 inside /opt.
Any palette NAME.soc may be simply pasted into /opt/libreoffice6.2/share/palette
(terminal sudo cp NAME.soc /opt/libreoffice6.2/share/palette/ Permissions did not need to be changed.)
It shows up immediately in all LibreOffice palette windows as NAME. Very convenient! Thank you, developers!
Note that the specific format must be exact. Just look at another one such as chart-palettes.soc to see the format.
I had to change one tag from an older version.

LibreOffice SNAP version gets installed from the Ubuntu Software Center. There are user config files in:
but the color files that used to be there in old versions are no longer placed there.

So to use a previous palette, one must download libreoffice and install it. One cannot use the SNAP version (presently).

The palettes are so much nicer! And having the Recent colors and Document colors is a Godsend! Thank you, thank you, Libre Office people!

Having the two versions is confusing because two separate applications appear in the Show Applications menu. One says LibreOffice 6.2 Word, LibreOffice 6.2 Calc, and the other says LibreOffice Word, LibreOffice Calc, etc. Right now they both are when opened.
(When I first asked the question, the snap and downloaded versions were different version numbers.)

Can this help?