Why Altgr mapped character sequence types only first character?

I am using Libre Writer 4.1 on Windows 7 x64. I made a custom keyboard layout with MSKLC 1.4 for an ASCII based font for Punjabi(Gurmukhi). e.g. if I typed Altgr+i,it would type ‘i+e’ that is ‘ie’. It works in MS Word or even in notepad as long as there is no keyboard shortcut mapped in Ctrl+Alt. But Writer types only ‘i’ and then assumes I typed Alt+e and opens a menu. Is Left Alt not for Menu and Altgr for character input? There is no keyboard shortcut,How can I disable Altgr from opening Menu? You can map a sequence of upto 4 keys in MSKLC 1.4 and it works in Word 2007 and notepad.