Why always extra step - need to "allow changes" - to get Libre Office to open?

Why am I asked every time if want to “allow this app to make changes to my device”, like we need to when installing new software, just to re-open the Libre Office app? Every other app on my laptop opens directly after I click on it. Not a big deal! But it would be nice to save a step and some time each time I open it. I wonder if there’s an installation setting, or something I could change to fix this?
I’m using Windows 10, version 20H2 x64, the last update was 2021-07, but this small issue goes back over a year at least.
Thanks anyone!

You probably need to add soffice.bin to your anti virus programs list of allowed/trusted/whitelist of programs. Look in settings, possibly under anti ransomware. Soffice.bin resides in the same programs directory as the Writer, calc, Draw, etc executables and you will need to point to the actual path and file rather than just typing in the name

Many thanks for the speedy response, Earnest. I’ve tried what I think you suggested. I went to Windows defender anti-virus and added an exclusion for “soffice.bin” by finding it in Windows (C:)\program files\Libre Office\program and clicking on it. It now shows there with its pathway . I also then rebooted, in case that was needed for the change to take effect. Sadly, the “user account control” box where I have to authorize the app to make changes still opens up when I click on Libre Office. I looked at where that click leads, and it’s the same path as the one added in the exclusion section.

Windows security also has an “App & Browser” control in its security suite. It looks like there are ways to protect “poor reputation” Apps that it finds there so they can still open. However, I went to its “protection history” and nothing is there - “soffice” or “Libre Office” don’t show up as Apps that were ever intercepted.

Did I do this the way you hoped? Please, any other ideas?

What version of LibreOffice is installed?

Defender has fewer obscure issues than other AV. It might be worth doing a virus scan on the computer just in case the dialog is from a virus rather than UAC or AV.

Many thanks. It is version 7.1.4 x64, but this was occurring with previous versions as well. I just updated from 7.1 I ran a full virus scan of every file about three days ago, and that did not report any issues

Hi Earnest,
Sorry. I just clicked on “version” in the Libre Office files, and I actually have: MsiProductVersion=

As the issue seems to affect just LibreOffice it might be worth going to Control Panel\All Control Panel Items\Programs and Features, right-clicking LibreOffice x.x and selecting Repair.

It might be related to a corrupted Windows user profile, possibly from when you upgraded to 20H1. There were documented cases of this at the time. See TenForums tutorial article Fix You’ve been signed in with a temporary profile Error

If no improvement, maybe If the Admin prompt has a greyed out or missing Yes button on TenForums provides a checklist to follow.