Why aren't new entry dates sorting properly in Version

I have a spread sheet with several columns, one of which is for dates and in YYYY/MM/DD format. This has worked fine until version Now when I enter new dates they appear as I want them to in the cells but on the input line they appear in this format: MM/DD/YYYY and when I sort by date the new entries are not integrated into the previous entries but appear at the top and are sorted by date and then the older entries appear below sorted by date. I’m using OS X 10.8.4.

Please take a look to this thread:

Thank you. I looked at the thread and read the articles. I tried changing the accepted date format to YYYY/MM/DD in the language settings in Preference however this hasn’t fixed the problem. I’ve also tried changing the format for the entire column to YYYY-MM-DD and only the entries made since the upgrade are affected so I still have two sets of entries being sorted separately.

I re-installed Version and still have same problem.

I was able to resolve this issue by adding an apostrophe in front of the date ('YYYY/MM/DD). The apostrophe does not appear in the cell but only on the input line. This works in Version 4.0.5.

Prepending an ’ apostrophe during input changes the cell content to text instead of date, so calculations involving such cells may not work as expected.

Sounds like you have a mix of text cells where the text looks like a date (the “old” dates) and cells with a value formatted as date (the new “real” dates). Numeric values are sorted before textual values so that makes sense. Apparently your old data is text instead of date values.