Why can't I add customer properties?

I am working on a book template and I wanted to add several “custom properties” in in the File +> Properties => Custom Properties dialog. Add seems to do nothing. I ma using LO6.2.5 but it behaves the same on RC of LO6.3

What “Add seems to do nothing” means? doesn’t a new empty entry appear in the list above, ready for entry? Just tested to be working with

As @mikekaganski already mentioned, it is not clear what exactly you mean and what you want to achieve exactly. Please add further information to your initial question. To do this, edit your question or write a comment if necessary. Please don’t write an answer that is not an answer to your initial question. Thank you.

You can also check the documentation to see if you can find an answer.

If you tried it the way shown in this attachment, I would suspect a corrupted user profile or a flaw in your install.
What’s your OS? Mine was Win 10.

For me this also worked with .ott and new documents derived from the template also showed the CusProp.

However, there are some bug reports probably related to the question.
You may try https://bugs.documentfoundation.org/buglist.cgi?quicksearch=custom%20property&list_id=990812.