Why can't I create field names more than 10 characters long in Base?


Today I tried the LibreOffice Base for the first time. I want to create a database for my home library. So I used a database Wizard to create a database and then added a table to it. But the problem currently is that I cannot assign a name with more than 10 characters long to any field. Moreover, if I use the Latin characters, I can type 10 symbols, but if I use Cyrillic characters, I can only have a name of 5 characters length. I suspect, this is somehow connected to UTF-8 (2 bytes per symbol).

In any case, is there a way I can give the table fields name more than 10 characters long?


I couldn’t reproduce this problem, which would otherwise be a bug. I was able to create field names with more than 10 characters and populate a test database. Which LibreOffice version are you using?

I use LibreOffice- from Gentoo GNU/Linux repository. The “About” dialog says:LibreOffice 3.5.0rc3 ID сборки: 350m1(Build:13). Thank you!

Hi @v_2e, Have you had a chance to try the latest 3.6 or 4.0-beta builds? It’s possible that the limitations you were seeing last year have been removed. If you have time, please test and let us know. Thanks!

Hello @qubit1! I tried LO today, but the problem is still there. Only 10 charachers-long name is allowed.

I’m using LibreOffice Build ID: 350m1(Build:102) on Ubuntu 11.10 and I can’t reproduce your problem either - could it be some limit or defect inherent in your language pack?

This is kind of off-topic, but here goes: Have you looked at any Linux collection manager apps (gcstar and tellico)? I was also going to do a database for my books, but it was SO intimidating. With gcstar, I enter the ISBN number and it collects info from an online database (author, title, publisher, etc.). I have put in 600+ books in a just few days.

Hello! I tried with LibreOffice Build ID: 350m1(Build:202) and got the very same limitation - 10 characters for field names in tables. As for your suggestion about other dedicated software, I’ll try some of them. Thak you.

Per @v_2e:

Hello @qubit1! I tried LO today, but the problem is still there. Only 10 charachers-long name is allowed.

Very bizarre. Okay, please file a bug report and explain your situation in detail including what works and what doesn’t (that bit about Cyrillic, etc…). If this isn’t an outright bug, then you can turn it into an Enhancement Request.

Good luck!

1 Like