Why can't I edit the Typography toolbar's macro?

I installed the Typography Toolbar from LO Extensions. I tried to use it, and an error occurred, as documented in bdf#106687. As a result of the error, the LO Basic editor “My Macros & Dialogs” opened, and revealed an LO Basic module for the Typography Toolbar.

But, I can’t edit this macro (to fix an apparent bug). I can click in the text. However, I when I type, the text of the macro does not change. There is no beep or error message.

I can also try to edit using the Select Macro button in “My Macros & Dialogs”. I click the button. A “LibreOffice Basic Macros” dialogue appears. In the left pane, I select My Macros > typo >_ General . In the right pane, there is a long list of macros from this module. I select the first macro, “help”, and click the [Edit] button.

An error alert “BASIC Syntax Error [OK]” appears. I click OK. I am now seeing the line of the macro with the syntax error, rather than the macro which I selected. I can scroll through the module, but no matter what I type, the macro doesn’t change.

Is the “_” between “typo” and “General” significant?

I am using LibreOffice on Mac OS El Capitan 10.11. Sorry for not mentioning that before. I don’t have the permissions to edit my question to add this information.

I suppose you’ve installed the extension for all users? It seems that in this case, you need to use an external editor to edit the macro.


This does not apply to me. I installed the Typography Toolbar extension for my own user. Also, that forum post [Solved] Cannot edit macro code is for Windows XP and dates from 2010. I am using LO and Mac OS El Capitan 10.11. (I didn’t mention that in my question. I’ll add it.) Do you think it’s likely that the same constraint applies to my situation?

Given that you installed the extension per user, I am unsure whether it applies.

I saw your OS from your bug report, so I was aware of it when wrote my answer. I am sure that the link I gave is applicable to any OS with multi-user support.

However, I have no experience with MacOS, so there could be additional factors to consider. It could even happen that on MacOS, not only all users’ extensions, but also personal extensions are affected.

I’m sorry, I was incorrect. It looks like I did in fact install the extension for all users. Thus your answer does apply. When I install the toolbar for my own use, I can in fact edit it.
Sorry, I don’t have the karma to upvote your answer at the moment. I will when I can.

It is a problem that LO doesn’t make it clear which Extensions are installed for all users, or that an Extension is read-only. There is apparently a bug about this problem, but I can’t find it (see discussion for https://bugs.documentfoundation.org/show_bug.cgi?id=106529).