Why can't I install on Trisquel 5.5?

On Trisquel 5.5, I extracted the downloaded installation files to a folder on my desktop. Here’s my console session, following the instructions given in the LibreOffice readme.

root@linus:~# cd /home/myusername/Desktop/LibO_3.6.4.3_Linux_x86-64_install-deb_en-US

root@linus:/home/myusername/Desktop/LibO_3.6.4.3_Linux_x86-64_install-deb_en-US# dpkg -i *.deb

dpkg: error processing *.deb (--install):

cannot access archive: No such file or directory

Errors were encountered while processing:

I can’t understand why this would happen. Of course there’s such a file or directory!

@Uglyface200 You heavily edited this question. Does my answer still apply?

Yes. For archival purposes, this question originally concerned Debian 6. The reason is that I tried Debian briefly before switching to Trisquel. Trisquel is based on Ubuntu, which is in turn based on Debian. So the same problem applies.

Change to the DEBS subdirectory in the LibO_3.5.4.3_Linux_x86-64_install-deb_en-US directory, then run the dpkg command.

I’m an idiot. It worked like a charm. Thank you!