Why can't I (re-)install Libre Office?

Earlier this morning, I had Libre Office on my other laptop so I thought I’d look to see if there were any updates. I found a and decided to install that on the same laptop. (Laptop is running Windows 10.) The install insisted on my closing Edge and Firefox first - which had never happened during any other install of Libre Office - so I closed them but then the install failed a bit later with an error saying it had insufficient authorization to install in the Libre Office directory. It suggested I retry while signed on as an Administrator. I am an administrator on that computer but it failed anyway.

I tried to reinstall so that I’d have a working version of Libre Office but that failed too on the same authorization issue.

What the heck is going on? I installed that copy of without any difficulty at all a couple of months ago on that same laptop using the same ID.

How do I fix this?

I finally solved the problem by rebooting Windows entirely and then installing Libre (with Edge and Firefox not running). This time it worked and gave me no strange errors. I used the same laptop and the same ID, which was an Administrator.