Why can't I use find for quotation marks?

I am using LO Writer with Linux Mint 16 Cinnamon. I just tried searching for quotation marks (‘ and “), and can’t find either type. In a file that has plenty of both, every time I try a search for either I am told that none was found. I can’t recall whether I have searched for them earlier, so I can’t say whether this is a new bug or not.

I have no idea whether this is a bug or a problem with regular expressions, since I don’t have a list of the latter for LO. I don’t think that’s the problem, since it makes no difference whether regexps are turned off in the replace dialog.

Are you using “straight” quotes ( ’ and " ) to look for curly quotes ( ‘ ’ and “ ” )? AFAIK, these are distinct searches. Also - could you fix your question text? It should be about “quotation”, not “question marks”, I take it. :wink:

No, it was about quotation marks. You are right that what I can’t find is only “curly” quotation marks. But I have no idea how to search for them, since I have no way of typing them into the search box.

One way to search for “curly” quotation marks is to copy one from the text and paste it into the Find and Replace Search for box. Another is to open the Find and Replace dialog and key Ctrl-Shift-S. This will open the Special Characters dialog where you can choose the character. Another way (in linux X11) is to open the search dialog and key in Ctrl-Shift-U followed by the unicode digits 201C or 201D.

To add to previous - some of the regex help is out of date anyway. But if you do CTRL-H to get search/replace dialog, enable “Regular expressions”, put [\u201C|\u2018] into the “Search for field”, and hit Find All, you’ll get all opening double and single curly quotes. I normally do the copy/paste thing myself.

To add to the mess, then there are a bunch of different quotation marks, like 99-high, 99-low, 66-high, as well single versions, even one mirrored 99-high: ‘’‚‛“”„‟, plus the usual single ’ and double " marks. And I forgot the angled quotation marks. So with regular expressions enabled you could search for [‘’‚‛“”„‟'"«»‹›] to find any quotation marks.