Why "crash" when save to Dropbox root?

why does Libreoffice “crash” when I want to save a file into the root folder of my Dropbox account?

I’m running on mac OSX 11.3.1 and dropbox v122.4.4867

I’ve granted both Dropbox and LibreOffice full disk access - but why would they need that? It still doesn’t work.

What I experience when trying to save a file in Libreoffice in the Dropbox root folder is 2 things:

a) LibreOffice freezes and I get the Spinning Beach Ball of death until I Kill it
b) the Dropbox app says it starts syncing a particular subfolder of the dropbox “root” dir, always the same folder which I in dropbox smart sync have chosen to be “online only”.

NO I do not select that subfolder in that LibreOffice save window. I don’t select anything except for choosing Dropbox in the left side column.

I can choose to save on a local folder without any problems, and I can also save in my iCloud drive without any problem.

IF I in Finder choose a subfolder in dropbox and pull it to the left side column and I then select that folder in the left side column from LibreOffice and save the file there, then there are NO problems - even though that folder is also somewhere in my Dropbox “tree”. If I then choose to save the file again under a different name and select the dropbox root folder then - BAM! Libreoffice crashes again.

Why does this keep to happen?

Have you ever tried (manually using a terminal / without using LibreOffice) to create a file whose name is starting with a . (dot) in your dropbox root directory (to create hidden files sometimes is forbidden in root directories of network services)?

If not - try to create such file (e.g. name it .~lock.test.ods#, which would be the name of a file required to be created when editing a Calc document called test.ods)

JonSweet16:Dropbox jonbendtsen$ touch .~lock.test.ods#
JonSweet16:Dropbox jonbendtsen$
JonSweet16:Dropbox jonbendtsen$ ls -la .~lock.test.ods#
-rw-r–r-- 1 jonbendtsen staff 0 May 13 16:14 .~lock.test.ods#

JonSweet16:Dropbox jonbendtsen$ touch .foo
JonSweet16:Dropbox jonbendtsen$ ls > .bar
JonSweet16:Dropbox jonbendtsen$ ls -la .foo .bar
-rw-r–r–@ 1 jonbendtsen staff 1077 May 13 16:09 .bar
-rw-r–r–@ 1 jonbendtsen staff 0 May 13 16:09 .foo

That does not seem to be a problem in the Terminal App.

I also just tried in Geany, and that was no problem either.

So anyway, even if creating a .DOT file was illegal, why does Dropbox start syncing a subfolder, a specific subfolder in that it is the same subfolder all the time, whenver LibreOffice tries to save a file in the Dropbox root dir, no other Apps seems to do this and when in a subfolder this does not happen either.

The subfolder that dropbox starts to sync has never been opened in Libreoffice, it is not the newest, not the oldest, not first alphabetically, not last either, and even when looking at inodes (ls -i) it is in the middle of the list.

My comment was a comment about to check creating . files is / is not the problem. So according to your test, it is not the problem.