Why dialog box is said " The specified device is invalid " when I tried to save with remote file

I try to saving this file with save remote file and select with OneDrive’s service, yes I filled username and password correctly and It’s prompt with dialogbox with authentication link to accept the permissions on OneDrive, when I accepted the permissions on its link then I copied authenticated with code to let program known about add service on it, but nothing happen on dialogbox, usually It’ll add service on dialogbox immediately, but I got this dialogboximage description

I tried about 3-7 times, but results is same as nothing happened
I working on : Windows 8.1 Pro with WMC (x64) :: LibreOffice version : (x64)

Same problem with v running on Ubuntu 18.04. Received email from MS stating:

Microsoft account
New app(s) have access to your data
LibreOfficeDev connected to the Microsoft account

But unable to get beyond the error box shown in original post.

More OneDrive testing:
Tried using a fresh app password for my MS account, using a new browser guest session to avoid any 'conflicts;. Tried with Chrome and Firefox browsers. Each time I tested, I removed the LibreOffice entry from my MS account “Apps and services you’ve given access”. Each time I received a MS email stating that a new app has access to my data.
The return code from the blank MS Office Auth page has a URL that is 94 characters long. Wonder if this is getting truncated somewhere to a shorter string, and thus rendering it unusable.

Have not tried Google Drive.