Why do I get unlicensed message when I open saved file in Libreoffice calc spreadsheet?

After saving the spreadsheet, I always get a message from Microsoft saying I am using an unlicensed product when I open the file. The saved file becomes inactive because it does not save any changes made later on.

I don’t have this problem using Writer Document.

Is it Calc that opens? Or is it Excel from the trial version of MS Office included with most Windows versions?

Hi Earnest Al,
It is MS Excel that opens up. Am wondering how to avoid it opening up since it is included in Windows 10.

since it is included in Windows 10

No, it is not “included in Windows 10”, it may be just pre-installed as a “bonus” by helpful PC vendor. It’s safe to uninstall MS Office from your Add/Remove programs (if you do not need it), just as any normal application.

You can open Calc (Start menu > LibreOffice > LibreOffice Calc), and click File > Open to open an xls or xlsx file but you probably want to associate those file types with Calc.

You can associate file types to LibreOffice in a couple of ways:

  1. Click Start Menu > Settings > Apps > Default Apps > Set defaults by app > LibreOffice 6.4 > Manage. Click on .xls (and .xlsx) and select LibreOffice Calc as the default to open. Close window when complete
  2. In File Explorer right-click on an xls file, select from the context menu Open With. A dialog box will appear, click on the link more apps, if you can see LibreOffice Calc in the list then tick the box Always use this app to open xls files, select LibreOffice Calc and press the button OK. If you can’t see LibreOffice Calc in the list then at the bottom there is link for look for another app on this pc, navigate to scalc.exe (probably C:\Program Files\LibreOffice\program\scalc.exe), OK, OK. Repeat for .xlsx.

Cheers, Al

[Edit 2021-02-28 23:06 UTC - changed from LibreOffice to LibreOffice Calc in Step 1 as default to open]

Hi Al - Thank you very much for your help in resolving my problem. I used option 2 as option 1 didn’t work for me although I followed all steps to the letter. So once again, I am very grateful for your kind assistance!

If the answer helped then please mark it as correct by clicking the check mark icon. Thanks.