Why do I not have the UK English spellchecker

Had v5.3.5 and couldn’t get a UK English spellcheck. The language box was blank and would not accept the English GB option. Upgraded to v 5.4 and problem still there

You didn’t mention your OS - and that matters. For Windows, the installer contains all languages and their spellcheckers, but they aren’t selected for installation by default. To add them, you need to re-run the installation (e.g., using the downloaded installer, or Windows’ Add/Remove programs’ Modify feature) and select required components.

To add them, you need to re-run the installation

It is overkill if you only need a spell checker.

:slight_smile: really? Of course, it’s much more overkill to do to Add/remove programs and double-click on LibreOffice line then check components to add, then to search for a package on Internet, think if this will work with your program, download, and then to the same double-click and walk through the same installation process…

OS is Win 10 prof 64bit. The 5.3.5 version when installed was the 64bit version (is this where things started to go wrong?). The current Lib Office is v5.4 with GB help pack. So a reinstall HAS been done but to no effect. The spell checker comes up with “None” in the language box and will not accepy English GB when clicked on!

I didn’t mean a reinstall. I meant that you need to check that required components (GB spellchecker) are selected in the installer. If they are, then there’s a problem indeed. Helppack doesn’t matter.

Yes the English language is set for installation under dictionaries, and under additional interface languages both English GB and English USA are set to install. BUT after running yet another reinstall with these settings checked as correct the spell check comes up with “None” in the language box. Trying to select English UK from the drop down box containing “[None]” does not help.

Also tried removing and reinstalling v5.4 - no improvement! I think I’ll regress to 5.2.7

Reverted to 5.2.7 but the problem remains. Is there some registry info which is not being updated correctly? This seems to have happened since I tried installing the 64bit version. How do I clear the problem?

You may try to reset your LO user profile. I suppose the problem isn’t related to version or bitness, just somehow corrupted profile.

I use 64-bit version exclusively since 5.0, without issues.

Thanks - resetting the user profile worked. Safe mode worked OK so I reset and all OK. I suspect the problem may have been generated when I added some word to the user dictionary. Another effect was that the font I was using was not rendered correctly wrt character and line spacing. All OK after the profile reset. Thanks for the help!

By default, LO comes out-of-the-box with a minimal language pack, i.e. US English only. To localize it to any language, install one or more language packs. The same holds true for the English variants. The English language pack contains variants for UK English as well as for a dozen others (CA, ZA, …).

See your distro package manager. For Fedora, the name is libreoffice-langpack-en.

If this answer helped you, please accept it by clicking the check mark :heavy_check_mark: to the left and, karma permitting, upvote it. If this resolves your problem, close the question, that will help other people with the same question.

Hello @bigpighodges,

This extension includes the Dictionary, Hyphenation, and Thesaurus for English (UK) : https://www.weeklywhinge.com/files/en_GB_2_0_0.oxt

Source page: the weekly whinge » Blog Archive » OpenOffice 3 British English Thesaurus

image description

It looks that this extension is no longer developed.

Look here.

User profile was somehow corrupted … many thanks to Mike Kaganski … see above. I suspect the user dictionary may have become corrupted during an update with new words … but can’t be sure. Starting in Safe mode removed the problem and indicated an issue with the user profile. Thanks to all for your suggestions and Mike Kaganski for the way out of the problem.