Why do I not have thumbnails in windows explorer?

I have libreoffice 3.5, under windows 7 and (on another pc) vista. With windows explorer set to show extra large icons I get no thumbnail images for LibreOffice files (others remain ok - e.g acrobat).

Any one have any suggestions about how I can resolve this?

Can you please also tag this question with the “Windows” tag ? Thank you!

IMHO, the bug report mentioned by @Pedro1 describes a different issue. The question concerns thumbnail images when setting icons to extra large. The bug report concerns the preview pane of Windows Explorer.

Regarding thumbnail images: you can modify the LO config manually as described in this OOo forum thread. I can confirm that this solution works, but you should be warned: you’ll have to edit the config files manually with administrative privileges, which may break your complete LO installation!

If you don’t have experience in editing XML files manually, you should refrain from following that solution. It may be worth an enhancement request in the LO bugzilla system to make those config options available through the UI. (i didn’t check if there’ already such an enhancement request…)

Unfortunately this feature was broken in 3.5.0
You have two options: go back to version 3.4.5 or keep using 3.5.0 without this feature.
Eventually this will be fixed in the 3.5.x branch

fdo#39887 is currently marked as RESOLVED NOTOURBUG. It looks like Windows Explorer doesn’t currently support preview for documents in the ODF v1.2 file format.